3
$\begingroup$

So I've got a problem popping up. I was following this video tutorial https://www.youtube.com/watch?v=iPOSAJuoEmU&index=3&list=PLvFQDY1Hrbb41mId9Evuvz3pDrHaGFDYI

I have noticed however that many of my trees are floating above the planes they are supposed to be growing from, which causes the immediate problem of shadows only appearing under some trees. I've checked around online, but most Q&A's similar to this one are because the person didn't use "Hair" or had their trees at the wrong orientation. I have tried to do what these other answers I have suggested but without much luck.

I don't mind if the distant trees float, but the ones on the closest mountain face are very obvious in the render. So any help would be great! If I have to I will just go through and manually move them if there is a way to do that! I just need them firmly in the ground, so to speak haha.

Photo time Trees are above planes causing no shadows to appear

Showing trees that are correct and trees that are wrong

These are the trees the particles are modelled from

$\endgroup$
  • 1
    $\begingroup$ Are you using a displace modifier or another modifier that changes the surface the particles are emitting from? If so, you might need to check the modifier order to make the sure the particle system modifier is lower down and/or make sure 'Use Modifier Stack' is enabled on the particle system. $\endgroup$ – Ray Mairlot Sep 30 '16 at 0:07
  • $\begingroup$ I can't believe the answer was one (obvious) click away, selecting "Use Modifier Stack" worked. Let me just put on this "Beginners" hat haha. Thank you so much. Literally, instantly fixed. The trees are even appearing according to my weight paint correctly now which was another issue I was ignoring lol (and why I have the number of particles cranked to 10,000) I cannot believe it was that easy. $\endgroup$ – SierranFoxtrot Sep 30 '16 at 0:16
  • $\begingroup$ What other modifier are you using? I would like to write this up into an official answer (as opposed to a comment) so knowing why it worked would help. $\endgroup$ – Ray Mairlot Sep 30 '16 at 0:18
  • $\begingroup$ Sure thing, the only modifier I had on the plane was "Decimate" with "triangulate" turned on. And I do have them in the correct order, with the "Decimate" on top and the "Particle System" underneath. $\endgroup$ – SierranFoxtrot Sep 30 '16 at 0:31
3
$\begingroup$

If the surface that the particles are emitted from is affected by another modifier then you will need to make sure that the particle system's modifier is below the other modifiers. This is so that the particle system can 'see' the previous modifier's result (because blender's modifiers execute in the order they are in the modifier 'stack', with each modifier passing on its data to the next).

Another option you may need is the Use Modifier Stack, found in the particle system's Emission panel. This makes sure the particle system is seeing the 'final result' of all the modifiers being applied to the object before trying to emit particles.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.