1
$\begingroup$

I'm new to Blender and still learning how to make a simple character, but when I started creating the Armature the X-Ray Mode is not working probably. I enabled it and I can't see the bones. That makes it hard to create the character skeleton.

here are screenshots of whats happening:

enter image description here

enter image description here

enter image description here

Any help is appreciated ...

$\endgroup$
  • $\begingroup$ Please provide a bit more information. What settings have you tried? X-ray mode is working, I assure you that. :-) $\endgroup$ – Gunslinger Jan 19 '14 at 20:08
  • $\begingroup$ @Gunslinger I Added a bone , moved it inside my mesh and then activated x-ray mode and it didn't show me anything, i Uploaded a screenshot to see whats exactly happening :) $\endgroup$ – Souls Reaper Jan 19 '14 at 20:41
  • $\begingroup$ @SoulsReaper Can you share the file, you may have changed something elsewhere. Use pasteall.org/blend $\endgroup$ – iKlsR Jan 19 '14 at 21:15
  • 1
    $\begingroup$ In the upper left hand corner of the object properties (the cube icon), there's an option to pin the settings. This will lock the panel and prevent you from changing the settings of any other object. Deselect the pin and you'll be able to change the settings for other objects. Screenshot of the pin option: i.imgur.com/dR0jjBJ.png $\endgroup$ – CharlesL Jan 20 '14 at 1:02
  • 1
    $\begingroup$ Post reopened. @CharlesL Can you post your comment as an answer? $\endgroup$ – Daniel says Reinstate Monica Jan 20 '14 at 12:43
9
$\begingroup$

Your issue is you pinned the mesh settings in the properties panel, so you can change the settings of any other objects. Simply de-pin it so you can change the settings of the other objects:

enter image description here

Then, give the armature the X-Ray, because the object that has the X-Ray box checked is the one that will show through any other object. In this case, you want to to uncheck X-Ray on the mesh and check it for the armature.

| improve this answer | |
$\endgroup$
3
$\begingroup$

It looks to me as though you have x- ray set to the mesh; its the armature that should have x-ray checked not your mesh.

| improve this answer | |
$\endgroup$
  • $\begingroup$ man I already tried that and it's not working , I already uploaded my file if u want to check it out :) $\endgroup$ – Souls Reaper Jan 19 '14 at 23:43
  • $\begingroup$ @SoulsReaper looked at the .blend. This is actually your issue. The mesh is being X-Rayed instead of the armature. When you check "X-Ray" your making that object show through any other object. $\endgroup$ – CharlesL Jan 20 '14 at 0:44
  • $\begingroup$ Steve's answer was the problem. My mesh had X-Ray enabled thus conflicting with the Bones's X-Ray. Make sure your mesh isn't "doubling-up" on the X-Ray mode. $\endgroup$ – EndlessLife Sep 4 '15 at 0:52
1
$\begingroup$

Because the x-enter image description hereray should bone it is not the object

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.