3
$\begingroup$

The shadow on my smooth shaded sphere with hair particles just looks wrong: Jagged shadow on particle

Blender scene with wrong shadow

I use Blender version 2.69, normals are turned outside and there are no doubled vertices. Without hairs the shading is ok.

Thanks for help and suggestion to improve the look.

EDIT: To make the ball look more realistic I further changed the following things:

I made 2 particles - one with "Render -> Strand render" (makes hair really light) and one with "Render -> no Strand render" and less children hair (gives a dark accents to the other particle setting).

I also made a new material for both particles (for more natural looking):

  1. Material -> Diffuse -> Ramp from yellow to transparent
  2. Material -> Strand -> Root 0.25 (for thin root)
  3. Material -> Strand -> Tip 0.25 (for thin tip)

Patricles Settings for both particles:

  1. Patricles -> Velocity -> Normals 0.03 (longer hair)
  2. Patricles -> Render -> Random 0.05 (Shadow really get smoother)
  3. Patricles -> Children -> Render 50 or 300 (less children
    also helped to smooth shadow)
  4. Patricles -> Children -> Length 0.7
  5. Patricles -> Children -> Random 0.05 (looks more furry)
  6. Patricles -> Children -> Size 0.01

Ball with two particles and a separate material

The jagged shadows arent visible now. Probably the particles aren’t meant to be used with few short hairs where you can see the shadow through.

$\endgroup$
  • 2
    $\begingroup$ The hair particle you are using needs better setting for the Children panel, especially the Random value. $\endgroup$ – Leon Cheung Jan 19 '14 at 15:07
  • 1
    $\begingroup$ @LeonCheung, do you mind posting this as an answer? Makes searching for answers much easier. $\endgroup$ – CharlesL Jan 20 '14 at 1:05
1
$\begingroup$

According to your setting on the hair particle, the Random value in Children panel needs better tweaking, at least.

enter image description here

$\endgroup$
5
$\begingroup$

@Leon Cheung is almost right.

The hairs are coming out exactly parallel to the normal. Because all the hairs on each face are pointing exactly the same direction, the shading on the hairs is going to change sharply at the edge of each face, even though you're using smooth shading.

One way to solve this "problem" is tweaking the Random value on the children. This will prevent the hairs on one face from all pointing exactly the same direction. Another thing you can tweak is the random rotation. Just add a very small amount of randomness, and this will also keep them from all facing the same direction.

These solutions should work without having to make your hairs longer.

$\endgroup$
  • 1
    $\begingroup$ So nice of you to make the detailed explanation on it. :) I think the mesh should be further subdivided in order to dicrease this jagged look. $\endgroup$ – Leon Cheung Jan 22 '14 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.