0
$\begingroup$

I have a few seperate models imported from Sketchup, and I can select the groupings that I made in Sketchup, but there are some groupings that are incorrect (not the same as what was grouped in Sketchup). When I move one group of objects, sometimes there are some unrelated objects which move together with it. However, when I go into edit mode, they are unconnected.

They seem to be connected to random vertices at the grid origin.

I've tried:

  • 'L' - 'Make Local' - 'Selected objects' and
  • 'U' - 'Make Single User' - 'Object' - "Object & Data & Materials + Tex, to no avail.

I've also tried

  • 'Remove from group' among other group options, but they all still seem to leave the objects connected at the vertex near the grid origin, not allowing me to move/translate them as seperate selections unless I got into edit mode.

My question is

How can I ungroup these objects?

$\endgroup$
  • $\begingroup$ To make your question potentionally answerable please add screenshots of the mesh in Object and Edit mode. There isn't any notion as "groupings" in Blender. $\endgroup$ – Mr Zak Sep 27 '16 at 10:59
1
$\begingroup$

Your group is a single object. You can select the object, go into edit mode, then separate parts of the mesh into separate objects.

From Separating Meshes - Blender Documentation

In edit mode press the hotkey 'P'. Then select one of the option:

Selected

This option separates the selection to a new object.

All Loose Parts

Separates the mesh in its unconnected parts.

By Material

Creates separate mesh objects for each material.

If the parts are unconnected in edit mode (as you stated), use Separate > All Loose Parts.

They seem to be connected to random vertices at the grid origin.

If the parts are connected, You can try to can try to delete the vertices/edges before separating the mesh by loose parts. Otherwise you will have to select the part of the mesh, which you want to separate and separate by selected. (Useful: 'L' [Select Linked])

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.