2
$\begingroup$

Is there a trick to avoid that the triangles are visible in the reflection when I do a twist with a deform modifier?

See the file:

twist

straight

$\endgroup$
4
$\begingroup$

Method 1

You need to switch to smooth shaded mode with "auto smooth" enabled (auto smooth makes a hard normal on every edge that is greater than the set angle).

enter image description here

Method 2

Another method would be to manually mark the edges as sharp, then use an edge split modifier. First select all the "sharp" edges in edit mode, then hit Ctrl+E --> "Mark Sharp". (Make sure you already clicked Smooth in object mode)

enter image description here

Then add an edge split modifier that splits based on sharp edges.

enter image description here

Note: Hitting Smooth in object and edit mode do different things (you can smooth certain parts of the mesh in edit mode). For this solution, you will want to hit Smooth while in object mode.

$\endgroup$
  • $\begingroup$ Adding smooth shading is the same in both Edit or Object mode; the "Smooth in Object mode" you wrote is Smooth option uder Tools rollout > Shading in the Toolshelf. In Edit mode this is W > Shade Smooth or in the Toolshelf > Shading/UV panel > Shading rollout. $\endgroup$ – Mr Zak Sep 26 '16 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.