1
$\begingroup$

In order to texture my models, I use "Smart UV project" to generate the UVs, using a margin of 0.5 to 1 to prevent bleeding. That doesn't seem to mitigate the issue however. Whenever I paint on one part of the model, occasionally it will paint other parts as well. This picture seems to describe it:

enter image description here

From original link to picture:

Hi all :)

I made this mech - not wanting to spend the next month of Sundays UV mapping it, I did a faces unwrap in UU3D, which takes a couple of seconds. What this does is to lay each face out separately, similar to what Blacksmith does. No use as a template, but great for 3D painting.

Problem is, the paint bleeds through in all sorts of unrelated places - there are close to two hundred separate meshes in there. I realise that the unrelated faces are probably laid out close together in the map, but this paints perfectly in both Blender and Hexagon. I've checked the map and Carrara has not messed up - the faces are not overlapped and do not touch.

I've even tried mapping it with Blender's "Smart unwrap", which does something similar but with more detail. Again, this paints perfectly in both Blender and Hexagon, but I get the same bleeding with Carrara.

Another thing is that Carrara does not seem to respect shading domains. If I select a shading domain it does restrict painting to that domain, but when I select another next to it and de-select the first, it will paint over the first. Not referring to this model, but others that have been unwrapped conventionally.

Is this just how it is and I must look to another solution, or am I missing something here?

Has there been any improvement in C8.5 (I am using 8.1) ?

Cheers :)

Edit to add : I've taken a look at the 3D paint file and see that the faces it is bleeding to are not laid out close - they are scattered all over the place.

I don't know how to fix this issue, any help is appreciated. Thank you.

$\endgroup$
  • $\begingroup$ That si most likely bad uv unwrap, different island are probably too close to one another, so when you paint they bleed into other unrelated parts that happen to be close by in the unwrap. $\endgroup$ – Duarte Farrajota Ramos Sep 23 '16 at 16:49
  • $\begingroup$ Try using 'Smart UV Project' or 'Lightmap Pack' from Blenders unwrapping options. They are just as fast as any 3rd party app, and they should produce a UV map which works nicely together with Blenders Painting Tools. You will also be able to set a Threshold, so unwrapped areas never come too close to each other. $\endgroup$ – aliasguru Sep 23 '16 at 18:05
  • $\begingroup$ I did use UV Project though, and the islands are fairly far apart. $\endgroup$ – Yoshimaster96 Sep 29 '16 at 15:30
  • $\begingroup$ Another thing to look at is the Options tab in the tool bar where you can control the amount of bleed there - if you are having issues with too much outside the boundary of your islands, then you can turn down from the default 2 pixels to 1 or 0. Obviously this doesn't stop you from having problems with UV mapping. Also, make sure you haven't turned off culling and normal there, allowing to paint through by accident. $\endgroup$ – Craig D Jones Jan 31 '17 at 20:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.