4
$\begingroup$

I have a node grid that renders and adds 10 different layers together. I have added a composition node in the end of the node grid. Though when i Render (F12) it seems like only one of the layers in the composition is rerendered and the other nodes are just applied without rerendering. How can I make all nodes rerender when hitting Render(F12)?

Sorry if my question is unclear, I am a Blender beginner so find it hard to explain my problem.

Any help appreciated! Thanks! :)

Image

Currently I have to press each "green-render-button" (marked in image) to finally get the complete result. I would like to be able to just press Render (marked in orange) and have them all rendered into final image.

Obviously there is something I don't understand because I can't make sense out of it...

Here are the layer list render settings

$\endgroup$
  • $\begingroup$ Could you upload a .blend file that showcases the issue? What are you trying to achieve? If you can't upload a .blend file, try attaching screenshots to your answer, you can upload the .blend file here: blend-exchange.giantcowfilms.com $\endgroup$ – Georges Sep 23 '16 at 13:29
  • 1
    $\begingroup$ In addition to the nodes, please also give us a picture of your render layers setup in the properties window. $\endgroup$ – Ron Proctor Sep 23 '16 at 14:36
  • $\begingroup$ I have now tried adding more relevant information. I can add more information if needed. I can not upload the blender file though, because my work is for school and uploading it can cause troubles... $\endgroup$ – Sebbe Sep 23 '16 at 15:06
  • $\begingroup$ One more important thing to show is setup of the render layers settings located in the Properties Editor. It could happen that you checked only one layer to be re-rendered (the selected one); it's a small icon to the right from the render layers list. $\endgroup$ – Mr Zak Sep 23 '16 at 15:45
  • $\begingroup$ @MrZak added an image of the Render layer list. $\endgroup$ – Sebbe Sep 23 '16 at 15:50
3
$\begingroup$

You selected Only render the active layer option in the Render layers list.

screenshot of only active render layer will be rendered

With this option only currently selected render layer (active one) will be rendered while others won't be; thus while compositing you'll see new results only on this active render layer.
From manual:

Using Render Layers can save you from having to re-render your entire image each time you change something, allowing you to instead re-render only the layer(s) that you need.

Deactivate this option and all the Render layers will be rendered again when you press F12 (or with any other way).

$\endgroup$
  • 1
    $\begingroup$ Great you solved my issue! Thanks! All buttons in Blender can be quite overwhelming and confusing for a noob like me ;) $\endgroup$ – Sebbe Sep 23 '16 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.