3
$\begingroup$

I am making a 3D logo.

When I create a text object and use solidify mod to make it thicker it does this:

enter image description here

When I don't use the solid mod, and instead convert it to a curve to do a curve extrusion it does this:

enter image description here

Why is it doing this?

$\endgroup$
6
$\begingroup$

Did you try using the text settings rather than manually extruding it? http://i.stack.imgur.com/anj99.gif

$\endgroup$
  • 1
    $\begingroup$ Excellent thank you very much. This worked! $\endgroup$ – David A. French Sep 23 '16 at 0:25
  • $\begingroup$ Also, If I then convert this into a mesh or curve later will that mess it up? I want to eventually port this stuff to Unity. $\endgroup$ – David A. French Sep 23 '16 at 0:26
  • $\begingroup$ @DavidA.French Try it! I am fairly certain it will work. If not, just convert it to a mesh. $\endgroup$ – 10 Replies Sep 23 '16 at 0:27
  • $\begingroup$ I actually have a problem before that. I need to do some editing on it's composition before using it in Unity but it's acting super janky once I convert it to a Mesh. :( i.imgur.com/nwKU8ZR.png $\endgroup$ – David A. French Sep 23 '16 at 0:40
  • $\begingroup$ I'm not sure why that is happening. I think it is because the letters are connected. If in wireframe mode the model looks good, you could probably manually fix the faces. $\endgroup$ – 10 Replies Sep 23 '16 at 0:45
2
$\begingroup$

The missing fill in your curves is caused by overlap. If the curves self intersect Blender doesn't know how to fill them correctly.

Either:

  • Move them slightly apart in edit mode (just enough not to overlap), or
  • Use the offset option in Properties Window > Object Data (Curves) > Transform > Offset (be careful as too much offset will cause problems of their own) ; or
  • If you really must leave them exactly as they are optionally use a different material slot on each independent spline (this is a workaround for the problem but kind of works because Blender wont try to fill them together).

Again if you are working with curves don't use the solidify modifier, instead use the curve extrude option which should yield better results.

That being said, I think you started on the wrong foot, if you plan on curving your object the way you show in the image you will never get a clean solution from curves. Because of the triangle based topology of curve object you will never get a clean smooth curvature.

You can try and minimize it by using a Subsurf modifier but it will generally maintain it's triangulated appearance.

You should do this from scratch with a mesh object with an even quad based topology

$\endgroup$
  • $\begingroup$ Thank you very much. This helped a lot. I ended up getting it to work using the extrude text function. If I then convert this into a mesh or curve later will that mess it up? I want to eventually port this stuff to Unity. $\endgroup$ – David A. French Sep 23 '16 at 0:25
  • $\begingroup$ No, converting to mesh or curve should maintain it as is, just have in mind that converting to mesh is a 'destructive process' in the sense that you cant go back to a curve cleanly, so remember to keep a copy of the original object around. $\endgroup$ – Duarte Farrajota Ramos Sep 23 '16 at 0:34
  • $\begingroup$ Hmmm I just tried converting it to a curve and it did indeed mess it up. That was after I had applied a simple deform mod, so I'm going to try and see if holding off on applying that helps. $\endgroup$ – David A. French Sep 23 '16 at 0:36
  • $\begingroup$ This is how it ends up looking. Getting rid of the deform mod doesn't help. I realize that maybe this is just a problem with this font being poorly formatted but I had this same problem yesterday. I went through 7 hours of painstaking clean up. I tried using a PNG converted to SVG but it converted poorly and the points were all janky so I basically had to completely rebuild the extruded stuff. I thought a font would be cleaner. $\endgroup$ – David A. French Sep 23 '16 at 0:39
  • $\begingroup$ i.imgur.com/nwKU8ZR.png $\endgroup$ – David A. French Sep 23 '16 at 0:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.