2
$\begingroup$

I'm new to both Blender and Sculptris. I was working on another model and it has similar problem. I first thought there was some problem with mapping the texture file but it seems like the import process went wrong.
I decided to see what it would do if I just export the default sphere into Blender from Sculptris.

Importing default sphere to Blender from Sculptris:

How the sphere looks in rendering:

Thanks a lot!


Edits: I tried as suggested below to enter edit mode and hit ctrl+N. Something changed but it didn't solve the problem. Please see screenshots below.

With inside normals selected

Did I not get the ctrl+N right?


2nd edit: Here's the file.

$\endgroup$
  • $\begingroup$ Can you upload your .blend file to Blend Exchange? $\endgroup$ – Shady Puck Sep 20 '16 at 11:02
  • $\begingroup$ @ShadyPuck Just uploaded the file. Thank you for helping me looking into this. $\endgroup$ – PeterAnteater Sep 20 '16 at 17:31
3
$\begingroup$

Sculptris seems to mess a bit with custom split normals data (or the export routines at least). When Custom Normals are present, some functions of Blender won't give you the expected result (and recalculating the normals is one of them, as well as setting an Edge Split ange). Delete this data to free the normals again. You can do this in the Mesh Data tab using the Clear Custom Split Normals Data button:

clear custom normals

After this, all normals are pointing in the same direction again:

before

before

after

after

finally, recalculate the normals using Ctrl + N:

final result

$\endgroup$
  • $\begingroup$ Thank you so much! It worked! Would you mind elaborate more on how the normals are so important but invisibly (to me) problematic? $\endgroup$ – PeterAnteater Sep 20 '16 at 18:44
  • $\begingroup$ @PeterAnteater Those Custom Split Normals are additional shading information, often added by the source application from which you import your geometry from. It is used to fix shading issues when triangles become too distorted. Automatic normals calculation causes shading artifacts with smooth shading in such a case, as the shading algorithm tries to simulate a curved surface, when in fact it should stay flat. The CSN override this calculation, making Blender display the surface shading in a nice way NORMALLY. In your case, something goes wrong with them, so it's better to rely on auto calc. $\endgroup$ – aliasguru Sep 20 '16 at 19:42
  • $\begingroup$ @PeterAnteater some more info here: wiki.blender.org/index.php/User:Mont29/Foundation/… $\endgroup$ – aliasguru Sep 20 '16 at 19:43
0
$\begingroup$

This looks like a normals problem. Tab into Edit Mode, key A once or twice until everything is selected, and key Ctrl + N.

With strange normals:

enter image description here

After procedure:

enter image description here

$\endgroup$
0
$\begingroup$

I had a similar problem and here are the steps I took to solve it.

  • Reset your PRAM
  • Turn off the "accept only apple apps" setting in system preferences.
  • Reinstalled sculptris
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.