1
$\begingroup$

I have a surface with a Subdivision Surface modifier, and when I render it in Cycles, there is a black edge at the edge of the surface:

enter image description here

If I render it without Subdivision Surface it looks like this:

enter image description here

What could be the reason and how can I stop this?

EDIT:

After adding the Edge Split modifier as suggested by Shady Puck, the result looks as expected:

enter image description here

$\endgroup$
  • $\begingroup$ Can you upload the .blend file? $\endgroup$ – Shady Puck Sep 19 '16 at 23:18
1
$\begingroup$

I believe that you can minimize this by increasing the Subsurf levels and eliminate it with an Edge Split modifier. A clever combination of both may suit you.

Sorry for low quality:

enter image description here

$\endgroup$
  • $\begingroup$ Thanks a lot! Adding Edge Split modifier solved it for me. $\endgroup$ – Noidea Sep 20 '16 at 10:19
3
$\begingroup$

That's because you have smooth normals. Either set those faces to flat shading or enable Auto Smooth under Mesh Data.

$\endgroup$
  • $\begingroup$ could you explain a little bit what is the difference to splitting the edges? Do you mean it is because I don't have smooth normals? $\endgroup$ – Noidea Sep 20 '16 at 19:21
  • $\begingroup$ @Noidea Smooth shading your mesh can lead to this blackening of the edges...something I forgot to mention, but Xtremity remembered. $\endgroup$ – Shady Puck Sep 20 '16 at 21:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.