0
$\begingroup$

Render shader mode in the viewport is fine, but when rendering a final image, I get a strange black, blank image with a grainy, blurry light source as the only visible object. Anyone know what might be causing this? I made sure the correct camera was the active one. The strange thing is, the light source in the image doesn't correspond to the locations of my actual light source in the scene. Here's the render output image: enter image description here

And here's a screenshot of my viewport:

enter image description here

$\endgroup$
  • 3
    $\begingroup$ Do you have any renderlayers? Or perhaps other cameras? If not, is it possible you could upload your .blend? $\endgroup$ – gandalf3 Sep 19 '16 at 3:10
  • $\begingroup$ Check your scene, layer and mask on Render layers settings. Maybe you made and object to act as a camera. Cycles render active? $\endgroup$ – Jp Miralles Sep 19 '16 at 3:48
  • $\begingroup$ @gandalf3 I have other scenes, and other cameras in those, but none are active, and I made sure the correct camera is active. Sometimes I will get nothing but a blurry light source, and sometimes I will get an image taken from the point of view of a camera that doesn't exist, WITH a blurry light source overlayed across the top. The results are wildly inconsistent sometimes, even when no settings have been changed, and the camera has just been moved. I think I may have set an object to be the camera, but I don't see how that's possible as I have an active camera. Will upload .blend. $\endgroup$ – Sanix25 Sep 19 '16 at 17:47
  • $\begingroup$ @gandalf3 It would appear that I have solved the problem. The camera selected under "scene" settings was a different camera from the camera used in the scene I was working on. This led to the camera from Scene 17 (Camera.001 trying to render Scene 14, even though I had a camera from Scene 14 (Camera.003) set as the active camera. Under render layers, Scene 14 was set to render, even though a camera in Scene 17 was active, causing weird things to happen. $\endgroup$ – Sanix25 Sep 19 '16 at 18:32
1
$\begingroup$

The problem is apparently that the camera that was selected under the "Scene" panel was different from the camera that was selected as active in the scene I was working on. The scene that was set to render under "Render Layers" was different from the scene that the "Scene" camera was in, and so this caused it to give a weird, black output. It's been solved. Cycles now gives a normal image output.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.