2
$\begingroup$

My issue looks like this:

enter image description here

The wood simply tiles improperly. I have given it a smart UV unwrap and basic texture coordinates and it is looking pretty bad. I want it to tile properly, as the texture should, and not in a random way as you can tell from the picture.

This is my node graph:

enter image description here

How do I get the wood to tile seamlessly?

$\endgroup$
5
$\begingroup$

Basically it's a UV problem:

enter image description here

If faces A and B can be contiguous, at least one between B and E or A and E (my case) will not be seamless, unless you want this effect which is really fake:

enter image description here

Anyway, for the first option, in edit mode select those edges: AE, ED, EC, DC, AF, FD, FC; Mark as seams, U to Unwrap.

For the second option place your viewport as you want to see the cube, select all vertices and press U "project from view".

I noticed also that in your node system the coordinates mapping affects only one of the 3 textures, which generally is an error.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.