1
$\begingroup$

In an animation scene of mine, I render most of the scene in Cycles and only the volumetric light in BI using a fully linked copy of the original scene where only the layer with the spotlight is actually rendered and the other layers are used as a mask. The problem is that the rendered search light does not match the preview of the cone that I see in non-rendered 3D view (with the "show cone" option enabled, obviously).

To illustrate, here's what it looks like in solid view:

enter image description here

And the exact same frame in rendered view:

enter image description here

As you can see the cone is much narrower than in solid view. In other frames, the rendered cone also appears to point at a slightly different place than the solid view.

Any ideas what might be causing this? Where should I check? Could this be some sort of cached setting (I did tweak spot sizes and directions after creating the linked scene)? Where would I reset this?

I'm currently using Blender 2.69.8 Fastest Build from graphicall.org but also had this problem with the original 2.69 release.

[originally posted as part of the question "How do I properly set up a spotlight cone?"]

$\endgroup$
2
$\begingroup$

This is because you have scaled the spot light in the 3D view. Scaling the spot light seems to effect the render in strange ways (the cone seems to get larger but the illuminated portion does not).

You can clear the scale with AltS. Then you can make it the proper size again, now using the settings in Properties > Object Data.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.