1
$\begingroup$

I've been animating a character and everything's been fine until I tried to move the "Belly" bone's location. At first, I wouldn't get any errors, and when keyframed, the belly wouldn't move. It would just stay in the last position I moved it in. Rotation's fine, and every other bone is fine, but this one's not.

Even in the properties, the rotation and scale values were yellow, showing a keyframe, but I couldn't keyframe the location values - they just stayed green.

Then I tried fixing it and I think I made it worse, not sure what I did. Now it won't let me keyframe it at all - location OR rotation. enter image description here

I need to be able to animate at least the belly's rotation and location.

Here is my .blend file -

$\endgroup$
2
$\begingroup$

As the error message hints, your animation channels are locked:

enter image description here

You need to click the padlock icon next to the bone name in the Dopesheet Editor to unlock them all. You probably just clicked it by accident. This solves being able to insert new keyframes, but the bone still doesn't move when animated. This is because the location channels are also muted:

enter image description here

Locking protects the animation channels from being edited (inserting/deleting keyframes) and muting temporarily disables them (hides their effects).

$\endgroup$
  • $\begingroup$ Oh my gosh -facepalm- thank you for going to the effort of figuring that out. Couldn't for the life of me figure it out. I'm at work right now so I can't access the file to double check, but with all of that unlocked, are you able to animated its location now? I may have clicked that in the process of (trying) to figure out why it wouldn't animate. $\endgroup$ – Joseph Clark Abraham Burgan Sep 15 '16 at 13:54
  • $\begingroup$ @JosephClarkAbrahamBurgan You're right, that didn't fully solve it. I've found an additional step that needs to be done. I'll edit the answer. $\endgroup$ – Ray Mairlot Sep 15 '16 at 13:57
  • $\begingroup$ @JosephClarkAbrahamBurgan This should work now. $\endgroup$ – Ray Mairlot Sep 15 '16 at 14:03
  • $\begingroup$ Interesting, I didn't know about the muting option. Must have clicked those by mistake and not noticed it. Thank you. $\endgroup$ – Joseph Clark Abraham Burgan Sep 15 '16 at 14:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.