1
$\begingroup$

I have setup a simple scene with some hills (one big object) and dam with water. Dam consists of multiple objects, they are set up as fluid obstacles. Dam breaks (parts of dam are animated with keyframes) and water should start to flow through valley.

But, fluid baking stops on higher fluid resolutions (for example 300) somewhere in the middle of my animation when dam breaks.

What I have already tried:

  • applied scale and rotation on fluid objects
  • removed double vertices and recalculated normals on fluid objects
  • run blender from command line and also with -d switch (to see debug output), but haven't seen any errors, it just suddenly stops
  • manually cleared the fluid cache folder (deleted all the files)
  • set all fluid obstacles to Free Slip (as advised in Blender Cookie Fluid Simulation Tutorial, part 3)

I am using blender 2.69 64bit on Ubuntu 13.10.

Here you can download my scene (it is my first try with Blender, so it is very simple) - scena1_2.blend (30 MB - sorry for that size, some textures are included...)

$\endgroup$
  • $\begingroup$ From the sounds of it, it bakes fine at lower resolution? It's hard to say where the problem is without a Blend file. $\endgroup$ – Mike Pan Jan 16 '14 at 4:07
  • $\begingroup$ Your file bakes fine for me at 300 resolution using Blender 2.7 (it did fail with 2.69 though). $\endgroup$ – gandalf3 Mar 21 '14 at 0:22
  • $\begingroup$ Im just having the same problem on Blender v2.76. Using a Resolution of 200 with 1 Subdivision in the Fluid Boundary, makes the baking stop automatically without warning. On lower resolutions like 100 its baking without interruption. $\endgroup$ – user18835 Oct 16 '15 at 23:59
1
$\begingroup$

There exists a workaround (at least it works 100% in my setup)!

I have enabled Export Animated Mesh option for all moving fluid obstacle objects and it works!

The only downside is that it enforces No Slip and is slower according to the documentation inside Blender.

$\endgroup$
-1
$\begingroup$

There are two things that might be going on.

  • Your cache is baking a different range of frames than are on your timeline. Make sure that the frame range in the cache settings is what you want it to be, because it might not be the same as your timeline range.

  • Your baked physics aren't getting freed, properly, and it's continuing to re-use old simulation data without re-calculating it.

    • This, in turn, might be for a number of different reasons:

    • You might not know that you have to "free bake" (in the cache settings) in order to run the bake again.

    • You might be using "disk cache" or "external." External uses a particular set of physics cache files and won't change them, even if you free the bake. This is unlikely, tho, because IIRC, the baking buttons go away when you turn this on.

    • Blender is acting up. There is a known issue with Blender releasing caches properly with any of the simulators, including smoke and particles. There are a few work-arounds. The work-around that I consider easiest is to change some "significant" value after freeing the bake. This will usually fully free the baked files and allow you to re-compute the simulation. There are some values that will do this and some that won't. You can tell when the files are freed because the colored line at the bottom of the timeline will change. Sometimes you ALSO have to track all the way back to the beginning of the animation. The most fail-safe method is to find the folder named blendcache_[filename] and delete its contents.

Hope that helps!

$\endgroup$
  • $\begingroup$ ad 1) it is not the problem, because when I set resolution for ex. to 80, it bakes whole animation $\endgroup$ – betatester07 Jan 16 '14 at 17:03
  • $\begingroup$ ...but when you go back to another resulution, it doesn't bake completely? $\endgroup$ – Matt Jan 16 '14 at 17:05
  • 1
    $\begingroup$ @betatester07 I have had this too.. Is it possible you are running out of memory? $\endgroup$ – gandalf3 Jan 16 '14 at 18:12
  • 2
    $\begingroup$ @betatester07 I think it's a bug, you might want to try reporting it. For what it's worth, the same thing happens in this Blender Cookie tutorial. He managed to get it to work by "making the simulation easier". $\endgroup$ – gandalf3 Jan 17 '14 at 9:20
  • 1
    $\begingroup$ @betatester07 Have you reported this as a bug yet? If you aren't planning on it, do you mind if I use your blendfile to report it? $\endgroup$ – gandalf3 Jan 28 '14 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.