9
$\begingroup$

Is it possible to play an animation in the viewport at a slow framerate?

Just because of the rather heavy scene it's already going at about 8 fps, but I would like to be able to play it even slower (an in a controlled manner) for the purpose of recording an animation with automatic keyframes.

$\endgroup$
5
  • $\begingroup$ I wish Frame Rate in the render settings was an arbitrary value, instead of a pull-down list. That'd do exactly what you want :-/ $\endgroup$
    – Matt
    Commented Jan 15, 2014 at 21:57
  • $\begingroup$ @Matt ...? Really? Because there is a Custom option in that pulldown, perhaps that's the answer :) (will test shortly) $\endgroup$
    – gandalf3
    Commented Jan 15, 2014 at 22:05
  • $\begingroup$ Lol, I had already typed up a whole answer before I remembered that it was a list, not an arbitrary value... but I also forgot about the custom option. Lemme know, and I'll post the answer. $\endgroup$
    – Matt
    Commented Jan 15, 2014 at 22:08
  • 2
    $\begingroup$ @Matt It works, thanks. For some reason I didn't think the render frame rate affected the viewport.. $\endgroup$
    – gandalf3
    Commented Jan 15, 2014 at 23:27
  • $\begingroup$ I'm changing the frame rate and it doesn't affect viewport... also I didn't find this custom option under render tab.. any directions? $\endgroup$
    – RollRoll
    Commented Sep 12, 2015 at 22:56

2 Answers 2

7
$\begingroup$

The Frame Rate in the render settings should also control viewport playback. If you choose the "custom" option and set it to 8, it should make the viewport also play at 8 fps.

enter image description here

$\endgroup$
3
  • $\begingroup$ I didn't get it, I set my to 29.97 fps and it is still slow (feels like 2fps).. $\endgroup$
    – RollRoll
    Commented Sep 12, 2015 at 22:55
  • 3
    $\begingroup$ If you have a heavy scene it could be that your computer can't keep up with the specified framerate. Try enabling Frame Dropping in Timeline > Header > Playback and see if that makes a difference. $\endgroup$
    – gandalf3
    Commented Sep 13, 2015 at 0:43
  • 1
    $\begingroup$ As gandalf3 pointed out, if your scene is heavy than Blender / your computer can't keep up with the set framerate. That's usually shown in the viewport by a framerate in red. Red color means "I know I'm supposed to play it faster, but I can't." The viewport playback should use that setting, but there are some factors that slow it down. A lot of geometry for example, setting the viewport to "Rendered" instead of "Solid" or "Wireframe", complex or high resolution simulations like smoke (even if baked)... $\endgroup$ Commented Apr 9, 2021 at 13:59
0
$\begingroup$

I've been looking into this for a long time. from what I found, there is no way to change the viewport fps as of right now. That may change as more new versions of blender are created. For now, the viewport fps is determined by how fast your computer runs. While your animation is playing in the viewport, it will give you the fps it is playing at in the top left or right corner. It should change very frequently as your animation continues playing. I guess if you want it to play slower, than you have to make your computer slower.

$\endgroup$
1
  • $\begingroup$ That's not true as others already commented. The viewport uses the render fps setting, but the scene might take up to much resources to play it (shown in red if it can't keep up). Which means, if your computer can play it at 8 fps, than you can set it to 4 fps and it should work fine. The other way round it's much the same. Let's say you want an animation at 30 fps and it's a simple scene, Then the computer might be able to play it at 30 fps in the viewport and it will not play at 60 fps even if it could since it's set 30 fps. But if you change it to 120 fps it might get slower again. $\endgroup$ Commented Apr 9, 2021 at 14:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .