2
$\begingroup$

I'm running Blender 2.76 on Mint Linux. Normally when I output sound from a newly installed application, I am used to going into PulseAudio Control and selecting the correct audio device. I am using Nvidia HMDI audio. See the screenshot. I have the option of selecting the correct audio device but when I click it, nothing happens.

I'm relatively new to Linux (1 month) and very excited to use Blender as a video editor, this issue is holding me back.

Any help would be greatly appreciated.

Correct Audio Device in PulseAudio Control

$\endgroup$
  • $\begingroup$ Interesting.. I can reproduce this here on archlinux, but I have no idea what's going on. I did find a similar sounding issue which appears to have been overcome, but I didn't see much useful info there.. $\endgroup$ – gandalf3 Sep 13 '16 at 3:30
  • $\begingroup$ Maybe related? blender.stackexchange.com/q/60683/2843 $\endgroup$ – Samoth Sep 13 '16 at 10:24
  • $\begingroup$ I've looked at that before posting. The Built-In Audio Analog Stereo doesn't work for any of my applications in pavucontrol. ALl other applications (including other video editors like KDENLIVE, OpenShot) are all set to HDMI Audio Controller (HDMI 2) and the sound works fine. Blender is the only one which it doesn't. $\endgroup$ – jeremyofmany Sep 13 '16 at 12:22
  • $\begingroup$ well , i have the same problem with blender 2.78,the device stays on HDMI , i cant select my usb audio althoug it appears on the options. Anyway , it works with jack... $\endgroup$ – Francois Bonin Oct 22 '16 at 7:19
1
$\begingroup$

I resolved the issue by updating from 2.76 to 2.78 RC1 using the following 3 commands: sudo add-apt-repository ppa:thomas-schiex/blender sudo apt-get update sudo apt-get install blender

This added SDL as an option under User Preferences > System > Audio. I was then able to select the correct audio device in PulseAudio Volume Control (pavucontrol).

Cheers!

$\endgroup$
0
$\begingroup$

it seems that Blender makes the choice of its default output, for me , with 2.69 its my usb-audio card, with 2.70 and above , HDMI audio.in all these cases , i cannot change the selection in pavu-control...too bad obliged to stick with the old version.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.