2
$\begingroup$

enter image description here

so i know this is a weightpainting issue, but i have no confidence in my weighpainting skills, so whenever i try to fix it it just comes out worse and the deformation gets worse for some reason. can someone tell me how to fix it? .blend

$\endgroup$
3
$\begingroup$

This is a common issue in automatic weighting. There is no "one click solution", so I can only propose some tips to improve your weighting skills:

1 - put your subsurf modifier after (down) the armature modifier and enable two little buttons that let you see the changes you'll make in edit mode and weight painting mode.

enter image description here

2 - in edit mode, if you select one vertex you can read the weight assigned to every bone - vertex group in the "N" panel, vertex weight tab. enter image description here

3 - in edit mode select some vertices (tipically some edge rings), then switch to weight paint mode and click the red highlited button: your weight painting will apply only to the selected vertices enter image description here

4 - if you select some vertices you can directly assign a weight in the vertex properties, vertex group tab.enter image description here

Always consider that every vertex is moved by all the bones to which a weight is assigned.

Hope it helps!

$\endgroup$
  • $\begingroup$ Very useful answer! In addition you may check the Show Weights checkbox in the Mesh Display panel of the properties shelf (N). It'll display the weights while in Edit Mode. $\endgroup$ – Paul Gonet Nov 20 '16 at 21:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.