6
$\begingroup$

I've been designing a building in Blender 2.77a. Tried making the external walls out of scaled and altered cubes, but I had a lot of overlapping faces issues. I then went back and redid it with just planes; now the source of my question is how can I take the shape of the walls, which are made of various sizes of planes and scale it or alter it so that the planes can be made thicker without losing the shape of the structure? Extruding then scaling on one or multiple axis results in glitches in the mesh where the overlapping from alternate positioned planes mix up.

As a bit of information to assist possibly, I have tried doing this same building with Archimesh which works fine for single story simplistic buildings but crashes if making multistory, and cannot do interiors easily. When I made the walls with the solid cubes that were shaped there was so much overlap the Boolean tool actually glitched leaving hangover after vertices were deleted. I have never found a real way to scale or alter even slightly complex shapes without them messing up.

this is the current state of the walls which need to be thickened without shape/structure loss

$\endgroup$
  • $\begingroup$ Have you tried Alt + S? It scales along the normals, and assuming all your normals are pointing the right direction (A to select all then Ctrl + N if they're not), it should work! $\endgroup$ – Shady Puck Sep 10 '16 at 15:17
  • $\begingroup$ i have tested and its one of the things i tried originally still results in it scaling oddly. $\endgroup$ – Flamesofshadow Sep 10 '16 at 21:08
  • $\begingroup$ @Flameofshadow Try keying A to select everything, then W > Remove doubles. Then try my method. If that works, please consider accepting my answer. If it doesn't, consider uploading your .blend file to Blend Exchange. $\endgroup$ – Shady Puck Sep 10 '16 at 21:20
4
$\begingroup$

In addition to using a Solidify modifier, you could scale along normals.

Key A once or twice until everything is selected. Key Ctrl + N to Recalculate normals. Set the Pivot point to 3D Cursor (.). Key E, Alt + S, Shift + Z, drag your mouse around, and hit Enter when you're happy. This will extrude, scale along normals, and only scale on the X-Axis and Y-Axis.

Note that you may have to hit Enter between extruding before scaling.

Edit:

Before doing the above steps, Tab back to Object Mode, key Ctrl + A to open the Apply menu, and select Scale. Tab back to Edit Mode.

Here is your .blend back. To go on from where I left off, just key Alt + S, Shift + Z and knock yourself out :)

| improve this answer | |
$\endgroup$
  • $\begingroup$ scaling along normals freaks it out, i've had normals facing out and facing in and neither works correctly for scaling as it freaks out for some reason due to the faces being parallel to different axis, i do have a version of the same thing already done in cubes so its the right thickness but there is so much overlap even boolean cant get rid of a lot of it when deleted so if there is a way to fix that maybe its simpler. $\endgroup$ – Flamesofshadow Sep 10 '16 at 21:23
  • $\begingroup$ @Flamesofshadow Once you remove doubles, Ctrl + N will recalculate normals. Worst case, you can manually flip normals. $\endgroup$ – Shady Puck Sep 10 '16 at 21:24
  • $\begingroup$ normals/doubles arent really the issue because with the overlap on the other version its just two pieces that are over lapping in a + shape usually, i spend time lining it up correctly but the pieces have to be connected for when i do texturing, but obviously when i have two rectangles who are facing different directions vertesis dont line up well. for the current one with the planes i dont get why i cant get the solidify+shrink/fatten or even just regular extrude scaling to work it just simply is not having those y parallels. $\endgroup$ – Flamesofshadow Sep 10 '16 at 21:34
  • $\begingroup$ @Flamesofshadow Can you upload your .blend file to the link specified above and paste the link into your question or comment it? $\endgroup$ – Shady Puck Sep 10 '16 at 21:35
6
$\begingroup$

Solidify & Shrink/Fatten

A way to give thickness to planar object is the Solidify modifier you can find in the modifier tab of the object. As you want to keep the profile even, you should enable the Even Thickness checkbox:

enter image description here

This will keep the wall straight and clean till your current topology allows.

Once the modifier has been apply, the correct way to increase the wall's thickness only on the seleced faces is to use the Shrink/Fatten tool you can find in the Transform tab of the Tooshelf or call it with Alt+S shortcut.

enter image description here

Press Alt (or S) while ruiing the command to enable Even Thickness option to keep walls straight during the transformation.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Been looking for that feature for years! +1. $\endgroup$ – Shady Puck Sep 10 '16 at 15:25
  • $\begingroup$ i tested the solidify and then shrink/fatten and it only partly works, the solidify doesnt work for any of the planes running parallel to the y axis and it also causes the right wall at the bottom of the right curve in the image (the one running along x axis leading into the curve) actually stretches across the screen when i move the mouse when doing that. $\endgroup$ – Flamesofshadow Sep 10 '16 at 21:18
  • 1
    $\begingroup$ That's because your object is non uniformly scaled (modifiers effects are affected by that; see for example: Symetrical bevel or blender.stackexchange.com/a/34719/15140 ). If it suitable for your project, you should Apply the scale (shortcut: Ctrl+A in Object mode) $\endgroup$ – Carlo Sep 10 '16 at 21:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.