1
$\begingroup$

I'm trying to model my first car in blender. I started by creating the front wheel arch and then duplicating it and scaling it to -1 in the Y direction to create the rear wheel arch. I then continued to extrude out the side of the vehicle from there.

enter image description here

Now I want to create a bridge between an edge towards the front of the car and one towards the back so I can model the area above the windows. When I select the edges and create a bridge (W > Bridge Edge Loops) I end up with a twist in the bridge:

enter image description here

I assume the edges have inverted Y axis orientations caused by me when I mirrored the wheel arches by scaling -1. I have tried recalculating all normals and playing with the Twist setting in the Bridge tool but I cant create bridge without the twist.

How can I fix my model so all faces, edges and vertices have the same Y axis orientation again?

$\endgroup$
  • $\begingroup$ Have you tried to recalculate normals? In Edit Mode select the whole mesh with A and press Ctrl+N. $\endgroup$ – Paul Gonet Sep 8 '16 at 15:42
  • 1
    $\begingroup$ Hi Paul. Yes I have recalculated the normals. Didn't make a difference. $\endgroup$ – John Sep 8 '16 at 16:02
  • 2
    $\begingroup$ Instead of recalculating all normals, select only the faces that are incorrect and use Flip Normals on just those faces. Since those faces appear to be 2D, Blender might not be able to automatically recalculate the normals because it cannot tell which is the correct direct for them. $\endgroup$ – Chris Dunaway Sep 8 '16 at 17:23
1
$\begingroup$

With those faces selected use ctrl-n to activate the Make Normals Consistent operator. If their orientation afterwards is not to your liking, use the Inside checkbox in the operator options panel to flip them. If you can't find that checkbox, go ahead and use the Flip Normals operator in the Mesh > Normals menu.

If this does not work, then the face sets probably do not share an edge. Maybe the Remove Doubles operator will fix that problem. Or you could just select the normals that are facing the wrong way and use Flip Normals on them alone.

$\endgroup$
0
$\begingroup$

Delete the faces you have select in the images.Press 3(numpad) ,then 9(numpad) ,then 5 (numpad) and be sure you are in ortho view (you can see this at the top left corner of the 3d viewport) then select the edjes you want to extrude and keep extruding them till you create the bridge and then navigate to the 3d viewport to see if you are happy with the result.

$\endgroup$
  • $\begingroup$ You can also try using other spaces like the local or normal space $\endgroup$ – palkonimo Sep 8 '16 at 15:57
  • $\begingroup$ xlsx your answer works as an alternative method to create the geometry but I want to know why the bridge tool wont work in the first place. I suspect I have created an anomaly in my mesh. $\endgroup$ – John Sep 8 '16 at 17:23
  • 2
    $\begingroup$ The Bridge function normally needs two separate edge loops to join together. You don't appear to have this, so it's just trying to make do with what it has to work with. It's not the right tool for what you're trying to do. $\endgroup$ – Anthony Forwood Sep 10 '16 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.