1
$\begingroup$

I asked this question a few weeks ago, but I guess I didn't explain it enough. I am a programmer so sorry if this is a stupid question.

I have a scene with a camera that has an animation fully setup. I was told you can go to render animation with that object that has the animation selected to quickly render all frames of that animation, however when I do that all I see is black, besides a few objects in my scenes that have a "glow" material.

I have a light "sun" pointing towards everything else, so it should be rendering the light, but for some reason it is not. The thing that confuses me more is that when I got to the bottom of the 3d editor to select show in "solid", "material", "wireframe", and "rendered" all those, in rendered it shows up fine.

And just to be clear cause people in the previous post seem to think I'm talking about the video being black, I'm not. I'm talking about when I go to "render animation" in the rendered tab it renders the animation frame by frame as black.

If you need screenshots or even the file let me know and I would be happy to send it.

$\endgroup$
0
$\begingroup$

The box called Sky has a Background shader. This shader is only meant for the world, and it is ignored on anything else. While the box is hidden from the vireport, it is still enabled during render, and it occludes the background light coming from the world. If I give it an Emission shader, I get this.
enter image description here

If I disable it altogether, I get this.
enter image description here

The sun lamp is a special type of light, that basically only gives a direction and a strength, and act like it is always outside the scene, regardless of where you actually put it, so even if it's located inside the Sky box, the box occludes its light. Take a look at Lamps in the Blender online manual.

$\endgroup$
  • $\begingroup$ I never knew things aren't active wouldn't be used in rendering, thanks so much this has been annoying me for weeks, I guess i took the word sky "box" to literally lol $\endgroup$ – FireStone720 Sep 8 '16 at 5:29
  • $\begingroup$ @FireStone720 You're welcome. In the outliner, there are several icons next to the names of each object. The eye icon is for showing/hiding an object in the viewport, and the camera icon is for enable/disable an object during render, and they are not linked. $\endgroup$ – Duane Dibbley Sep 8 '16 at 5:33
  • $\begingroup$ oh cool also i'm not gonna post this as another question in case someone can answer it, but is there a way to reduce the file size, cause right now my animation when rendered is almost 2million kilobytes... or 2gb ? $\endgroup$ – FireStone720 Sep 8 '16 at 22:19
  • $\begingroup$ @FireStone720 There are many ways to control the filesize. For a more in depth question on video encoding, I think you should ask over at Video Production, and for how to set the proper parameters in Blender, would be better off in a separate question, because it's beyond what the comment section is for. $\endgroup$ – Duane Dibbley Sep 8 '16 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.