1
$\begingroup$

First of all, I know that this question has asked here before, but the answer brings more problems and doesn't fix mine. That method causes the object to fall through my plane after the influence is reduced to 0. I have tried adding a LocRot keyframe before and after the influence keyframe to keep it in the right spot, but then my object just stays in place once the influence is set to 0.

Some more about my project:

I am trying to animate a small shield rolling down a hill. To do this, I am trying to use a combination of a Follow Path Constraint tracked to a bezier curve, and at the end have the object use Rigid Body Physics to naturally fall and bounce.

Link to my .Blend (Dynamic should be checked in RigidBody under Physics properties tab, I forgot to turn it back on before uploading. This did not fix my problem.

In all, I'd basically like to have my object follow the path then use rigid body to emulate it bouncing and falling on a plane.

$\endgroup$
3
$\begingroup$

Leave the Dynamic enabled, and keyframe Animated instead, on the same frames as you keyframe the Follow Path constraint. Keyframe it to on at the last frame where the constraint influence is 1.0 and to off on the frame after, where the influence is set to 0.0. Hover the mouse on the checkbox and press I to keyframe it.
enter image description here

I changed the Shape setting in the Rigid Body Collisions on the plane from Convex Hull to Mesh, but that isn't strictly necessary if you're ok with the buckler bouncing a little above the plane.
enter image description here

To bake the physics, go to the Scene window and click Bake or Bake All Dynamics in the Rigid Body Cache panel. And if you're only going to render 120 frames, as set in the blend file, you may as well change the end frame for the physics too. No use baking frames you're not going to render anyway.
enter image description here

Here's a short animated gif. I apologise for the quality. I used Blender's built-in screencast, and apparently it wasn't able to keep up with the speed at which the buckler was moving.
enter image description here

$\endgroup$
  • $\begingroup$ Thats great, but how do I keyframe the animation instead? Are the checkmark boxes affected by keyframes? Do I bake the keyframes, and if so, do I bake from the physics menu or the object menu? Also, can you add a screenshot of the settings? I'm not sure the extent of Blenders Screencast, so don't worry if its too difficult. The gif is just very blurry and I can't make out the settings, though it looks like you have keyframed the surface response. Might just be my screen though. $\endgroup$ – Rug Sep 7 '16 at 2:10
  • $\begingroup$ @Rug I'm sorry, the gif wasn't meant to show the settings. Just that the physics work. I assumed my text was explanation enough. To keyframe the Animated property, just hover the mouse on the checkbox and press I. Bake from the Rigid Body Workd panel in the Scene window. I'll edit in screenshots shortly. $\endgroup$ – Duane Dibbley Sep 7 '16 at 2:21
  • $\begingroup$ Cool, I will give that a try. Thanks again, screenshots when you get a chance would be stellar :) $\endgroup$ – Rug Sep 7 '16 at 2:34
  • $\begingroup$ @Rug The screenshots are up. And a slight correction to my previous comment. Rigid Body Cache, not Rigid Body World. I didn't notice it until it was too late to edit. $\endgroup$ – Duane Dibbley Sep 7 '16 at 2:37
  • 1
    $\begingroup$ @Rug Done. I had to remove a lot of stuff, to reduce the file size. So all that's left is the plane, the shield, the camera and the two paths. And now I'm off to bed. If you need further help, you'll have to be patient until someone comes along, be it me or somebody else. $\endgroup$ – Duane Dibbley Sep 7 '16 at 3:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.