I need to print out a toothed ring but it prints out as a disk, ie with the ring filled in. On checking the stl file in blender it has non-manifold edges and I think these confuse the printer. I can see that the inner part of the ring is non-manifold in Edit Mode using CtrlShiftAltM.

The file is at: https://drive.google.com/open?id=0B3_qq9691bVuSEduM3Y5bWdRY0k


While removing doubles with a high merge distance of 0.1 or more will remove some of the problem, fixing the non-manifold issue manually will take a very long time as you need to fix each and every errant vertex.

However, if you don't need to maintain the exact same mesh and can live with a very very close reconstruction of it, you can fix the non-manifold issue automatically by using the remesh modifier, and then the decimate modifier to reduce the polycount back to sanity.

Here's the setup: enter image description here

After adding the modifiers with the parameter values specified above, you can either directly export to STL (File --> Export --> Stl) or apply the modifiers and then export.

  • $\begingroup$ Many thanks for your helpful answer which has enabled me to progress with a 3D print of an orrery from thingiverse $\endgroup$
    – rupert
    Sep 3 '16 at 18:05
  • 1
    $\begingroup$ Just a note that it may make more sense to print this ring "upside-down", with the flat part on the printer bed. Otherwise supporting material may be needed. $\endgroup$
    – rdtsc
    Dec 19 '18 at 2:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.