5
$\begingroup$

How can I translate or extrude something in inches? If I hit E or G then type a value, it's taken as feet, and if I try to type in ", it's simply ignored.

I live in metric land, but I do understand imperial units quite well. I usually don't bother setting Blender to anything but the default BU; I simply take 1 BU as 1 m.

Now I'm trying to model something whose measurements are defined in feet and inches (a pool table with several randomly placed balls). I see several workarounds to the above problem.

Model in BU and scale down properly once I'm done.
Take 1 BU = 1".
Convert the measurements (or use the converted measurements from the WPA site), and model by the conversions.

However, I want to model it directly in feet and inches. If nothing else, I might learn something new: working with imperial units in Blender.

$\endgroup$
  • $\begingroup$ Make It 0.0254*12 then increment Unit will be in Inches. $\endgroup$ – Nimesh Mar 6 '18 at 7:54
5
$\begingroup$

A bit of googling lead me to Metric & Imperial Units in Blender.

@DemonFate's answer, made me try manually setting the scale to 0.0254, which is 1 inch expressed in metres. I assumed the scale was a conversion from BU to whatever unit I wanted. But from the link above, I realised that when Blender is set to Imperial, the scale is a conversion from feet to whatever unit I want. Hence setting it to 0.08333 does the trick. To get the best precision, type in 1/12 and hit Enter, and Blender is smart enough to calculate it.

enter image description here

There are drawbacks, but I can live with them. The Scale and Location values in the Object tab and in the Properties panel now increments in thou, and all values typed in manually when grabbing or extruding are now taken as inches.

$\endgroup$
  • 1
    $\begingroup$ The scale alters the visual size in the 3DView - when entering a size or position you can always enter imperial sizes as 2' 6" and metric as 5cm 3mm $\endgroup$ – sambler Sep 3 '16 at 6:10
  • $\begingroup$ @sambler Yes, I've realised that as well, but that has to be done either in the tool options (which can be done in both Object and Edit mode) or in the Transform section of the object's data (while this too can be done in both Object and Edit mode, doing it in Edit still affects the entire object and stores the values in the Object, as if the transforms were done in Object mode). $\endgroup$ – Duane Dibbley Sep 3 '16 at 9:10
4
$\begingroup$

I’m new at Blender, but it appears that a simple way to input inches into an extrude command while in Metric Units is to select the region (1), type “EKEY” for extrude, followed by the preferred axis, and PRESS RETURN (do NOT type a distance before pressing return).

select region

Then, in the Tool Shelf the “Operator” area changes to “Extrude Region and Move” as soon as you press the return key. There will be a distance of “0m” for X, Y, and Z (2). In the axis you want to extrude, click on the “0m”, then change it to the distance you want, ADDING an “in”, a double quotation mark ( “ ), or “inch” after the number of inches (3). Press return and your Extrude takes place and the distance is displayed in whichever Units mode you’re using(4).

extrude region and move enter distance extrude complete

An added note: When in Object Mode, you can use any type of Units you prefer to change dimensions and/or transform entire objects in the Transform area of the Properties Region. (Use NKEY to toggle visibility of Properties Region.)

I am using version 2.77 of Blender on Mac (version 10.9.5).

$\endgroup$
3
$\begingroup$

In the scene settings you have to set the units to "inches". If you type in the translation menu eg. 5in or 5", it will convert it correctly.
enter image description here

$\endgroup$
  • $\begingroup$ Unfortunately it doesn't look like that here, but rather like this i.imgur.com/dSUvEPo.png $\endgroup$ – Duane Dibbley Sep 2 '16 at 20:20
  • $\begingroup$ Are you using Blender 2.77 ? Maybe you have to update your version to get the desired result. $\endgroup$ – Demons Fate Sep 2 '16 at 20:28
  • $\begingroup$ 2.77a. And that tab has looked the same since I started using Blender, which was something like 2.69 or 2.68. $\endgroup$ – Duane Dibbley Sep 2 '16 at 20:34
  • $\begingroup$ I have just upvoted, because I'm sure your answer works. But I can't verify it. Unless I find out why my Blender interface looks different from yours, and learn how to fix the difference, I can't really accept your answer. I will try to find the reason, and in the meantime I will see if another answer comes in. If none of that happens, I'll fall back to one of my workarounds. But thanks for the effort. $\endgroup$ – Duane Dibbley Sep 2 '16 at 20:52
  • 1
    $\begingroup$ Oh, actually you are right. I am using a beta build from www.graphicall.org . If you want the updated units menu i recommend downloading blender 2.77.3 from that website. If you only want to use the offical blender version, i think you have to wait for 2.77b/2.78. $\endgroup$ – Demons Fate Sep 2 '16 at 20:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.