0
$\begingroup$

When I render preview my animation little twinkling particles appear.

I might have turned them on but since I'm new to Blender I don't know how to turn it off.

screenshot of twinkling particles


@Jaspa I'm sure that cycles did finish rendering. In fact, this was just a preview of a render (if that changes anything?). I'm posting another screenshot of a different position of my animation and there's no little dots to see on buildings, except on the building from a first screenshot in the distance.

dots on left, right building and river

dots on the building in the distance, but not on the others

$\endgroup$
  • 1
    $\begingroup$ You're sure that cycles didn't just not finished rendering yet completely? Maybe there were also too few render steps set, so he didn't finish. $\endgroup$ – lunjius Sep 2 '16 at 16:37
  • $\begingroup$ several related information here for instance blender.stackexchange.com/questions/4980/… $\endgroup$ – lemon Sep 2 '16 at 17:01
  • $\begingroup$ @Jaspa I'm sure that cycles did finish rendering. In fact, this was just a preview of a render (if that changes anything?). I'm posting another screenshot of a different position of my animation and there's no little dots to see on buildings, except on the building from a first screenshot in the distance. $\endgroup$ – Tina Draščič Sep 2 '16 at 21:55
  • $\begingroup$ What are you lighting the screen with? Are you using a lamp or an HDR environment map? (My answer could be updated a little bit to suggest multiple importance if using an environment map) $\endgroup$ – tschundler Sep 2 '16 at 23:33
  • $\begingroup$ Possible duplicate: blender.stackexchange.com/q/1703/599 $\endgroup$ – gandalf3 Sep 3 '16 at 3:16
1
$\begingroup$

As Jaspa mentioned you should go to render tab, then go to sampling and increase the render samples to something like 1000 (the more the higher the image quality) then hit render (this option is in the render tab)

$\endgroup$
1
$\begingroup$

The "little particles" are often referenced as "fireflies".

In this case, the reason they show in one scene but not the other is because of the light bouncing from the reflective surface, which is less even in brightness than diffuse surface. Increasing samples can help, but it's usually not the right approach. There are a few things that can help:

Render Settings

  • Set a value for Clamp Indirect so somewhere around 2 +/- 1.5 - this limits the influence indirect lighting will have on your scene. Maybe even less than 0.5 in this case.
  • Try "Direct Light" (cleanest images but flat looking) or "Limited Global Illumination"
  • Be sure "Reflective Caustics" is disabled
  • Try lowering the number of Glossy bounces to 1
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.