6
$\begingroup$

Dyanmic Paint has two possibilities for the "Format": Vertex and Image Sequence.

Two options for dynamic paint

I've been able to do it with Vertex, but when I do it with the Image Sequence setting, I'm able to output the .png files successfully, but when I render, I don't see any paint. Could someone walk me through the steps involved?

My scene has just the default cube (set to Brush under Dynamic Paint settings) and a plane scaled up 5 times (set to Canvas).

Scene Setup

(I'm using Blender Internal render if that makes a difference) (Blender 2.69)

$\endgroup$
  • 1
    $\begingroup$ Sounds a lot like a tutorial request - please be specific about what you're having issues with and someone will easily help you. Dynamic paint is fairly intuitive, so unless you're stuck on something specific it should be fairly easy to figure out. $\endgroup$ – Greg Zaal Jan 13 '14 at 6:51
  • $\begingroup$ I wasn't sure if I should list out all the steps I went through since it would make for a long question. Unfortunately, I don't know where I went wrong. My final result was that I ended up with a bunch of .png's that appeared to me to be correct, but when I render, my plane doesn't display any texture. I gave the plane a texture and set Source to "Image Sequence". I also enabled "Auto Refresh" in the Texture tab. $\endgroup$ – Garrett Jan 13 '14 at 7:25
  • $\begingroup$ I thought posing the question in this format would make for a more generally useful answer, but are these kinds of questions discouraged? I wouldn't have asked if I had found a good resource online explaining how to do this. $\endgroup$ – Garrett Jan 13 '14 at 7:27
  • 1
    $\begingroup$ @Garry For this site it's generally best to try and say exactly what your problem is. (If you want a walkthrough of some sort you are best of looking around for tutorials on youtube etc.) If I were to answer this now, I might not have even gone past the baking part and as a result I would not have answered your real question. Anyway, It sounds like your problem might not even have anything to do with dynamic paint, just with loading in image sequences. Could you edit your question with more detail about exactly what you did and what happens? (and possibly some images and/or a file?) $\endgroup$ – gandalf3 Jan 13 '14 at 7:39
  • $\begingroup$ Right, I understand. I'll keep that in mind going forward. I actually just figured out what my problem was: I selected the plane, went straight to the Texture tab and hit new texture. It therefore created a texture that wasn't linked to the plane's material (since the plane didn't have one). So should we just delete this question then? $\endgroup$ – Garrett Jan 13 '14 at 7:53
6
$\begingroup$

It turns out I was making a silly mistake, but I'll run through the steps in case it helps.

I'll assume we're starting with the default cube and the plane scaled up.

Plane and cube

1) UV map the plane

Select the plane, hit TAB to get into Edit Mode, then press U. This will bring up a menu. Select Unwrap. Hit TAB to get back to Object Mode.

enter image description here

2) Give the cube some motion

In order to actually see the paint, you have to make the cube move around. So give the cube some motion in the XY-plane.

3) Enable Dynamic Paint

Select the cube, go the Physics tab of the Properties window. Enable Dynamic Paint, click on Brush and then "Add Brush".

Now select the plane, click on Dynamic Paint. Make sure that Canvas is selected. Hit "Add Canvas".

Change Format to "Image Sequence". Under the Dynamic Paint Output header, click the box next to "UV Map" and find your UV map you just created and select it. (It'll probably be called "UVMap")

Just underneath UV Map, you can select where you want the texture images to be outputted to. Hit "Bake Image Sequence". I believe you have to bake it. You can't just render.

4) Give texture to plane

With the plane still selected, go to the Materials tab of Properties window, and hit New to give a material.

Now go to the Texture tab. Make sure the Material Textures button is selected (this is where I messed up).

Materials Texture Button

Hit New to give the plane a texture. For Type, choose "Image or Movie". Scroll down to the header Image, and click on Open. Navigate to the folder where you outputted your images to and select the first image (probably called paintmap0001.png) and click on Open Image. Then look for Source, which you should set to Image Sequence.

Selecting Image Sequence

5) Render

That's all. Just render it and you should see the paint.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.