1
$\begingroup$

I banged my head yesterday, thinking my modeling was sloppy, but now I see the problem is somewhere else.

Take a look at the picture: notice the X-axis deviation!~

What I did: simply extrude the top-left vertex to the bottom-right vertex of the cube, using the Snap during transform option, set to snap to vertexes.

In every case, there is a deviation of sorts and will happen on one axis (always the third axis, which should always stay at 0, but it deviates instead).

Does anybody know what's causing this issue and how to fix it?

EDIT: If I wanted to simply connect those verts, I could have done it just as easily by selecting them both and press "F" to create an edge. That is not what I wanted to do.

What I want to do: basically, by extruding vertices to other ones using the Snap feature, I was measuring if there were deviations in my mesh geometry, removing those extrusions after (with Ctrl-Z). The Extrude feature can easily be used as a measurement tool like that - even extrude a face toward a desired edge or vertex, to check how it sits in correlation to the face being extruded.

But with those deviations that happen even on the basic starting cube, how in the world can I use the Snap-to feature when it produces such deviations?

$\endgroup$
  • $\begingroup$ Are you talking about the less than 1/1 000 000 of units ? If yes, you can't. This is due to floating point values accuracy. $\endgroup$ – lemon Sep 1 '16 at 11:27
  • $\begingroup$ I just tried the same on a default cube, blender 2.77, and I get - X 0.000 - Y 2.000 - Z -2.000 I can't replicate your picture having different precision levels on x,y,x... ? $\endgroup$ – m.ardito Sep 1 '16 at 11:42
  • $\begingroup$ @m.ardito Did you use the snap during transform option (set to vertex)? Because I just extracted a second portable Blender to another location and it shows that issue as well!! $\endgroup$ – trash Sep 1 '16 at 11:53
  • $\begingroup$ yes, I used the vertex snap (extruded with E hotkey) but I get x,y,z vector coordinates all with 3 precision digits, while you have y,z with 3 and x with 7... that's weird, imho... $\endgroup$ – m.ardito Sep 1 '16 at 11:56
  • $\begingroup$ @m.ardito The only face of the cube, where there is no deviation when extruding the vertex, is the top/bottom part (Z). Every other side gives deviations of 0,000002, 0,000004, 0,000007 and 0,000009 respectively... $\endgroup$ – trash Sep 1 '16 at 12:24
1
$\begingroup$

Try this - don't snap to anything. Get into Ortho view mode so you're looking flat at the side to be extruded, extrude one vertice only a small distance in the axis that will take it along top edge. Then press G and move your mouse down so the loose vertice is near but not touching the bottom right vertice.

Highlite the loose vertice, and with shift held, highlite the 2nd vertice at the corner, press ALT-M and select "first to Last" or similar, to "marry them". (my term)

If that doesn't deform the cube's shape, do the same with the other side. Round it all off by removing any doubles.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.