1
$\begingroup$

I need to apply a texture paint to a mesh that already has vertex colors attached to it: Vertex paint mode

When I want to draw on this mesh in texture paint mode the vertex colors get applied too: Texture paint mode: The vertex colors obstruct most of the mesh

As you can see, the vertex colors make it hard to see anything of the texture paint in the dark areas. How do I disable the vertex colors during texture painting?

As a less important side question: How do I disable lighting as well?

I just want the pure texture to be displayed during painting.

$\endgroup$
1
  • 1
    $\begingroup$ You can enable Shadeless in your material to remove the shading. $\endgroup$
    – gandalf3
    Jan 12 '14 at 18:22
1
$\begingroup$

Switch to GLSL shading and enable Shadeless in your material settings:

enter image description here

With GLSL enabled in texture paint mode, wireframe view will display only the vertex colors, solid will display both, and textured will display only the textures.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.