2
$\begingroup$

I'm trying to render this lightning animation, and all the materials looks right (or at least how I want it to look) starting at frame 44. Every frame I render before 44, the materials render differently.

frames 43 and 44

The lightning is made of 3 curves. The centermost curve is the most thin, with an emission surface material to brighten up the second curve, which is slightly thicker around the first one. This one has a blue emission volume material. The last curve is a very thick curve with a blue surface emission material, and is invisible to the camera. This curve is just to provide some glow on the ground plane, as the thickness of the other curves is too small to actually illuminate anything in the scene. The lightning is animated by keyframing the bevel factor of the spline.

construction of the lightning - 3 curves

So what's going on here? There are no keyframes in the materials to cause this change. It looks like two of the curves might be overlapping? But how could that be if their bevel depth isn't animated? I tried turning off the motion blur, changing the camera angle, changing the bevel depth to make sure they aren't overlapping. No success yet.

$\endgroup$
1
  • $\begingroup$ What's your render device setting? CPU or GPU? If it's GPU, also try CPU. Have you rendered always the whole sequence or have you also tried to render only the two frames 43 and 44? Also, consider uploading your file to blend-exchange.giantcowfilms.com and posting the link in the question. Maybe some of us might try and different hardware delivers different results... $\endgroup$ Aug 31 '16 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.