1
$\begingroup$

It seems that something about the way I have jumped between Cycles and Blender render has caused issues with a file. I am new to render engines and not that experienced in Blender in general, so I have been disorganized about things and have ended up having to jump around.

Right now I want to do up this model with a diagram feel, so I switched from Cycles back to Blender render, in order to do up some flat materials and make them shadeless and such. I switched off nodes on the materials, and when there seemed to be issues, I deleted all the materials thinking maybe redoing them would help. The new materials have been assigned to the individual faces that have them.

The model renders pretty well. (It has a few issues due to quickie geometry but I can live with them for now.) But in Materials, Texture, or Solid view there are a lot of faces that turn black or xray - they make the things behind them in the same object invisible, as well as themselves. Recalculating normals has helped in some spots, but not others. In the case of the mirrors, selecting the mirrored faces and flipping those normals had no effect, or made the face x-ray. I checked for non-manifold geometry, and that isn't the cause. I get the feeling it is a normals issue, maybe I'm wrong.

I do have a version of this file from before the Cycles materials were added, but I wanted to know if there is a way to correct this.

render view of blender model render view looks mostly right

material view of blender model material view makes the mirror face black, other faces on that object invisible, and faces at the top of the tube x-ray

$\endgroup$
  • 1
    $\begingroup$ It looks like on some meshes you have inverted normals $\endgroup$ – Denis Aug 31 '16 at 17:25
  • $\begingroup$ @Denis I tried recalculating and flipping normals, and though that helped in some cases, it hasn't helped in the case of these objects. Perhaps this model deserves to be uploaded, but i'll pare it down a bit. $\endgroup$ – kim holder Aug 31 '16 at 17:31
1
$\begingroup$

Cycles materials are node materials, and the majority are not compatible with Blender Renderer. Changing them back to "normal" materials by toggling the nodes in the material tab under preferences view will fix their "blackness".

$\endgroup$
0
$\begingroup$

I suspect that you haven't Assigned the new material to all the faces in the object. For any object that you're having trouble with, tab into edit mode, select all the faces, select the correct material in the materials list, and click "Assign" under the materials list.

This will make all the faces use that material. It may be that those faces still somehow think they're using a material that doesn't exist anymore.

$\endgroup$
  • $\begingroup$ No, the material has been assigned to the specific faces involved. The correct materials are showing up in the render view. $\endgroup$ – kim holder Aug 31 '16 at 17:21
0
$\begingroup$

Blender render relies on light. Moving around the light source (or adding several) will fix this, thats why people often use cycles for testing the textures first.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.