0
$\begingroup$

From what I've seen, to bake physics you have a rigid body object in the scene and go the the "Blender Game Renderer" and press P. When I do this, physics fall and everything properly. However, when I press Esc to go back to editing or whatever, the physics aren't there (when scrubbing through keyframes). Here's a video for help: https://youtu.be/I2S8cX7LVDY

Here's one of the cell fractures rigid body settings: rigid body settings

$\endgroup$
3
$\begingroup$

You don't need to do this in BGE.

In object mode select your physic object or objects then in the Tools Panel select Physics and Bake To Keyframes.

bake

Blend file:

$\endgroup$
  • $\begingroup$ Using "Bake to Keyframes" does not work correctly. The object just remains still when scrubbing through. The settings for baking are default. $\endgroup$ – Josh Silveous Aug 31 '16 at 1:32
  • $\begingroup$ Do you need this to be done in BGE? In my case Rigid Body is done in Cycles Render. $\endgroup$ – cgslav Aug 31 '16 at 1:34
  • $\begingroup$ I've been trying in both BGE and Cycles. $\endgroup$ – Josh Silveous Aug 31 '16 at 1:36
  • $\begingroup$ Check blend file in my update. $\endgroup$ – cgslav Aug 31 '16 at 1:39
  • $\begingroup$ Your blend file worked fine. I scrapped my project and retried, now physics work fine. Not sure what happened there. $\endgroup$ – Josh Silveous Aug 31 '16 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.