1
$\begingroup$

I'm trying to setup my hotkeys so I can more easily sculpt with a tablet. As a part of this I tried to change the hotkeys for invert and smooth sculpting. By default this is done using normal modifier keys, in this case control or shift + left click. This works. But I wanted to use a regular key as modifier, A and S in my case.

So under Blender User Preferences > Input. Then 3D View > Sculpt there are three Sculpt options: Regular, Inverted and Smooth. There's a bunch of normal modifier keys, but there's a blank field where you can enter 'Regular keys as modifier'. But when I changed the settings for invert and smooth to A+Left Click and S+Left Click and tried this, they both only did regular sculpting. After fiddling with it for a bit I noticed it's not that the hotkey doesn't work, but that the left click sends you into regular sculpt mode regardless of what regular-key-modifier you press. You can notice this when you disable the regular sculpting tool (the one that only uses left click).

I assumed the regular key as modifier should work similar to the normal modifiers, but it seemed not to.

Is this a bug? Can someone reproduce this? Can someone help? I would really like to use a regular key and not control/shift/alt for this. Thanks :)

PS. In sculpt mode S is linked to the smooth brush, so you need to disable this hotkey if you want to reproduce this.

$\endgroup$
0
$\begingroup$

DerekWatts over at BlenderArtists answered my question in this topic.

Apparently it's a known issue and it's fixable by changing the order in which they appear in the hotkey list. Disabling the original left-click-only hotkey and add a duplicate at the bottom of the list fixes it.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.