0
$\begingroup$

I watched a tutorial on PBR (Physically Based Rendering (I guess)) - http://www.cgmasters.net/free-tutorials/realtime-pbr-in-blender/ and when I downloaded the file some setting were kinda different. I couldn't put reflection maps on the objects because the tab "Mapping" is missing. Also, there's Real-time HDR Image which blew me away since nobody did it (youtube videos). I replicated the world setup from Cycles since some nodes from Cycles seem to work in Real-time - GLSL (which is awesome), but it didn't work (the texture wasn't 360 like in the blendfile from cgmasters). In the nodes for the sphere whatever texture I click the specular map doesn't change in the Material Preview.

Is the code manipulated specifically for PBR or am I missing something obvious?

Also, I really need real-time HDRI so please help!

Update: I realized it's a test build version (2.78), it doesn't work with 2.77a, but the sphere texture still puzzles me (It doesn't update when I change it from the nodes), but it's a complicated setup so I should probably make a good study of it.

I almost forgot - I still can't aply an HDR image in the viewport (make it 360) and if it works from the cgmasters file, then it's possible. Please help!

The issue enter image description here

Blend File is here:

$\endgroup$
  • $\begingroup$ I've added your blend file to blend-exchange.giantcowfilms.com Please always use that site for uploads, as they guarantee the file will be around for a looooooong time. pasteall links will expire at some point. $\endgroup$ – aliasguru Aug 30 '16 at 14:04
  • $\begingroup$ @aliasguru Thanks. I'll check out the site $\endgroup$ – Vladimir Aug 30 '16 at 16:00
3
$\begingroup$

Those mapping settings will only appear if you are NOT using nodes to define your material in Blender Internal. Uncheck the button marked in red on the material tab to get the settings back as they are in the first screenshot:

mapping back

It makes sense, as you would - when using nodes - drop in a mapping node to the node graph to do the same thing. That's why the panels (and many other options) disappear.

Edit

Regarding the HDRI, the ability to show an HDRI directly in the Viewport has been added to Blender in 2.77, you can get the latest release (currently 2.77a) on the Blender website: http://www.blender.org. If you want the HDRI to also reflect on the objects, you'll need a development build from https://builder.blender.org/download/

Here is a screenshot taken from Blender 2.77a:

enter image description here

and this is the same scene in the current development build:

enter image description here

$\endgroup$
  • $\begingroup$ @Vladimir regarding HDRI I don't understand your question. Also, if that is something separate (not linked to the settings you were looking for), please consider asking another question just regarding your HDRI issue. Multi-questions are not allowed on BSE. $\endgroup$ – aliasguru Aug 30 '16 at 12:33
  • $\begingroup$ In the World tab when I check horison the image shows in the viewport as it is (it's not 360 like in the video). But in the blendfile from cgmasters it works. I can't figure out why. I'll also update the question $\endgroup$ – Vladimir Aug 30 '16 at 13:27
  • $\begingroup$ Do you just press on "horison" for the hdri, I'm still having trouble - pasteall.org/pic/index.php?id=106270 $\endgroup$ – Vladimir Aug 30 '16 at 15:56
  • $\begingroup$ No I don't press anything, I just open your file. Did you test it with the current release candidate for Blender 2.78, available from download.blender.org/release/Blender2.78 ? The world displays fine, the cube as well. The sphere has some trouble with the material, but I'm uncertain where this is coming from. If you use the cube material on the sphere, it shades. Also if you select the Output node for the reflection only on the sphere material, it works. Must be something in the node setup. $\endgroup$ – aliasguru Sep 4 '16 at 11:53
  • $\begingroup$ @Vladimir please test again with the 1.78 Release candidate (link in comment before), I simply download your Blend file without changing anything at first. With the exception of the Sphere, everything just works. BTW what are your machine specs? $\endgroup$ – aliasguru Sep 4 '16 at 16:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.