Disclaimer: I am aware that this question is very similar to these two and that the answer to my question would probably be applicable to them, too:

However, my situation is different from the two mentioned above in that the machine I want to render on is a physical machine that has an nVidea GTX 870Ti GPU (i.e. I definitely do want to render on the GPU, not the CPU) but it has no monitor attached to it - I only ever access it via RDP from my main workstation. Now, the RDP display driver apparently does not fulfill Blender 2.77's minimum OpenGL requirements and the fact that there is no physical monitor attached means that I also cannot connect via TeamViewer... (haven't tried VNC yet... would that work?)

I am currently working around this by using Blender 2.76 on that machine but I've already encountered situations where the render results differed from Blender 2.77 due to bugs that were fixed in that version and thus were unusable for animation rendering.

(Quick explanation on what I'm doing: I'm trying to distribute rendering of animation frames across multiple machines. For this purpose I have shared the project and output directories with the additional render boxes. I also have the "Overwrite" option unchecked and "Placeholders" checked. I.e. I'm not using any special network rendering addons.)

Is there any solution to this? Maybe a custom 2.77 build somewhere?

  • Will the problem solve if it was posible to connect with team viewer? – xlxs Aug 28 '16 at 13:39
  • 1
    Have you tried rendering from the terminal and using -b to start blender without a gui? See CLI options – sambler Aug 28 '16 at 15:03
  • @xlxs : Yes, it would work if I was able to connect with TeamViewer, however, as I wrote, that is not an option for me as TeamViewer apparently will not work without an active display which in turn would require either a physical monitor or an RDP session which is where the issue starts to bite itself in the tail... – Oliver Giesen Aug 28 '16 at 17:34
  • @sambler : TBH I have not tried that yet because the answers I linked to in my articles made it sound like Blender would always render on CPU rather than GPU when running in background mode which is not what I want... If that was a false assumption I will definitely give that a shot... – Oliver Giesen Aug 28 '16 at 17:38
  • is it posible-easy to have physical access to that workstation? – xlxs Aug 28 '16 at 18:20

The problem is that the Remote Desktop Protocol (RDP) does not allow for OpenGL, a workaround is using an app like TurboVNC. I've been able to render in headless machines that way with no issues.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.