1
$\begingroup$

I'm getting corruption in the blender UI that looks like some of the components are not being drawn correctly, overwriting parts of the screen. I've experienced these issues at various times - usually in the toolbox or other panels - and it was usually nothing more than a minor inconvenience as I could usually simply scroll the panel up or down a bit and they'd go away. However, now I've got the same issue on the node editor window in the compositor and it's making it pretty much unusable. Does anyone else experience this problem and/or have any ideas for a solution? It's sometimes tricky to take a screenshot as moving the mouse or swapping windows to the screenshot utility changes the pattern, but here's a (minor) example of what I'm getting :

Screen corruption in the node editor

The coloured triangles move components scrolled or selected

Often it's more colourful that that. The pattern changes as the screen is moved around or other elements are selected.

I've tried changing the Window Draw Mode, Text Anti-aliasing, Images Draw Method, etc. in the System preference screen but nothing seems to improve matters.

Any help very much appreciated as this is driving me a bit nuts at the moment.

In case it helps, this is on Blender 2.76a running on Ubuntu on an Acer Travelmate with 2Gb memory - earlier versions of Blender also had the problem but I just figured it was a glitch that would go away with later versions, but it didn't.

$\endgroup$
  • $\begingroup$ Don't know if it's a clue but in this case it seems that the 'Add' node has something to do with it as the image is missing and the 'Add' drop-down is missing its usual decoration. $\endgroup$ – Rich Sedman Aug 26 '16 at 22:08
  • $\begingroup$ What GPU are you using? What Ubuntu version are you using? Stuff like that matters. A lot. $\endgroup$ – metaphor_set Aug 26 '16 at 22:15
  • $\begingroup$ That is an issue with the GPU. make sure you have the correct drivers. Try to use the proprietary drivers and not the open source ones if you can. $\endgroup$ – cegaton Aug 26 '16 at 22:26
  • $\begingroup$ No GPU - CPU only. This is on lubuntu 16.04 - but I've been having the problem since much earlier versions. $\endgroup$ – Rich Sedman Aug 26 '16 at 22:28
  • $\begingroup$ I've tried searching for additional drivers and it did find one to install - it's now installed and rebooted but the problem still exists. In the preferences for Compute Device it's definitely set to CPU - no option for anything else. One thing I have just noticed is that if I switch off the thumbnail image on the Add node on my screenshot (by clicking on the circle at the top-right) or scroll the node so the image is at least partly off the screen then it's better - it's a reasonable workaround for now :) $\endgroup$ – Rich Sedman Aug 26 '16 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.