I've looked for an answer, and have seen that there should be an option on the import dialog. This is not the case for me. Blender 2.77, SVG 1.1 from Illustrator. Thank you.

  • $\begingroup$ Welcome to BSE. Please add some detail to your question, like where have you seen this option, a screenshot of the current result, etc. Thanks! $\endgroup$
    – aliasguru
    Aug 24, 2016 at 19:30
  • $\begingroup$ maybe related: blender.stackexchange.com/questions/46639/… $\endgroup$
    – user1853
    Aug 24, 2016 at 20:09

3 Answers 3


The SVG importer has no options.

SVGs are imported as curves.

2D curves can be filled or not. The fill settings are here:

enter image description here

If fill it's set to none, your curve will only be an outline.

enter image description here

Note that the outline will need some extrusion or bevel to be visible/renderable.

enter image description here


If you just want an object outline, you can go in with edit mode and remove interior edges and faces. Of course, this is less useful if the object is very complex.

Another option might be to select an outside edge in edit mode, then use Select > Edge Loops or Select > Edge Rings to get the outline(s) you want. Once you have those, you can separate the selection into a new object with Mesh > Vertices > Separate.

Edit: This is all assuming you convert the object to mesh first. :)

  • 1
    $\begingroup$ Best answer I've seen after a number of searches. Thank you so much. $\endgroup$
    – MarxMyth
    Aug 24, 2016 at 21:13
  • 1
    $\begingroup$ @MarxMyth If you find a good answer you should consider upvoting the question. $\endgroup$ Sep 16, 2016 at 15:59

You can run the following python script in Blender's Scripting workspace. Just select the curves you want no fill on and execute the code.

import bpy

#store the selection of objects in a variable
selected_objects = bpy.context.selected_objects

#loop through the selected objects
for obj in selected_objects:
    #check if the object is a curve
    if obj.type == 'CURVE':
        #execute the instruction to set the fill mode to none
        obj.data.fill_mode = 'NONE'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .