2
$\begingroup$

Are problems usual to arise in unwrapping a subsurfed mesh? Specifically in my case, I have a mattress that I have modelled for a bed, when I try to unwrap this the first problem that arises is the message that pops up in the info header,enter image description here,
first problem: what does the message mean?

The UV layout that I have created after hours of untangling, is(the green box here marks the area with the only pattern in the entire texture) :
enter image description here,
second problem: was this a proper way to uv unwrap the mesh.

Furthermore, I had created an experimental texture in GIMP which I applied to the mesh:
unwrapped image
but the render turns out a bit stretched:
enter image description here
What are all these problems? How can I fix them? What is the correct way to uv unwrap and texture a subdivided mesh?

I have also included the file; with the texture packed:

$\endgroup$
  • 2
    $\begingroup$ The message simply means that the scale of your mesh is not 1 (or equal) in every direction. This can explain the stretch problem of the second question. So ctrl+A the scale to apply then scale (set it to 1) and unwrap again $\endgroup$ – lemon Aug 24 '16 at 11:44
  • $\begingroup$ scaling the mesh would distort it from the room scene though $\endgroup$ – bzal Aug 24 '16 at 11:46
  • 1
    $\begingroup$ no... you will keep the dimensions : apply the scale (don't modify it) : ctrl+A then scale. Do it on a copy if you are not confident... By the way : your blend file does not include the texture you want to match with. Can you upload again with the texture packed in it ? $\endgroup$ – lemon Aug 24 '16 at 11:51
  • $\begingroup$ How do I pack the file, I am working in cycles, I can't find the pack option. $\endgroup$ – bzal Aug 24 '16 at 12:10
  • 2
    $\begingroup$ If your object was scaled in object mode, the dimensions used for mapping will be inaccurate. Read the following links: blender.stackexchange.com/questions/47318/… and blender.stackexchange.com/questions/7298/… $\endgroup$ – cegaton Aug 24 '16 at 12:10
2
$\begingroup$

The message is because the scales of your object are non uniform. That means that some axis has a different scale than the other (eg : (1, 2, 1)).

But, unwrap functions works on uniform scale. So, in order to keep the dimensions and unwrap with the good proportions, you need to apply the scale (with Ctrl+A then 'scale').

Here you can see the impact on the unwrapping :

enter image description here

By the way, it seems that your initial work on the UV map give few space for the main face of the mesh (it is in a small center part of the UVs). You should unwrap the main faces as 'big surfaces' in order to have the best benefit of the texture.

Something like that, which is obtained automatically adding seams to each corner :

enter image description here

$\endgroup$
  • 1
    $\begingroup$ @bzal, in that case, select the UVs of this part which is just colored and scale it down. The other part can be scaled up (as more space is available for it). Some points in this recent question can interest you too : blender.stackexchange.com/questions/61519/… $\endgroup$ – lemon Aug 24 '16 at 12:36
  • 1
    $\begingroup$ @bzal, you can unwrap using "follow active quads", or, in the UV editor use "UVs to grid in respect to shape" which comes from an addon called "UV squares" (github.com/Radivarig/UvSquares) $\endgroup$ – lemon Aug 26 '16 at 7:32
  • 1
    $\begingroup$ @bzal, nothing is straight in the model, the model is 15.244x9.338 (ratio = 1.63), the texture is 4028x3000 but the part for the drawing is 1103x533 (ratio = 2.07). So I don't know what you mean by stretches ? The best you can obtain is unwrapping with the first unwrap option as it will maintain the ratio the best as possible. If you try to align the UVs you'll obtain stretches. Here is the file with a simple unwrap but considering the ratio stretch are unavoidable <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=1834" /> $\endgroup$ – lemon Aug 27 '16 at 5:25
  • 1
    $\begingroup$ @bzal, These numbers are the lengths of the edges (an option in the information panel N). Concerning the mesh, I think you needed to make it unstraight to compensate the subsurf. But you should add cuts to your mesh differently to avoid that. Have a try : add a plane, add 4 subsurf subdiv to it (don't apply), then cut it in edit mode ctrl+R. You'll see that restraints the subsurf effect at the corners, and also keep the mesh straight $\endgroup$ – lemon Aug 27 '16 at 10:32
  • 1
    $\begingroup$ That should be better to chat about that (but I do not know how to...). What I meant is that your base mesh IS distorded and that UV unwrap (first option) compensate that. Once done you can also check "use subsurf modifier" in the operator panel (it appear on the bottom left just after you validate the unwrapping). But even if all that can compensate, the first step stay the mesh geometry, I mean "by itself", because it seems you want straight things but what is modeled is not straight because subsurf is used with wrong/not enough cuts $\endgroup$ – lemon Aug 27 '16 at 13:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.