2
$\begingroup$

enter image description here

When i try to bake my model it come up with the error message "no object or images found to bake to"

$\endgroup$
  • 2
    $\begingroup$ Also make sure that the object is not restricted from rendering. This isn't a problem for OP but someone else might run into this issue. $\endgroup$ – dexgecko Apr 28 '17 at 19:03
  • $\begingroup$ To me it happened because I still hadn't applied the Mirror modifier. $\endgroup$ – Rodrigo May 1 '18 at 13:18
4
$\begingroup$

You have to create an image first. To do so click new in the UV Image Editor. Create your image and with it selected click bake. This only works in Blender Render like that. If you want to bake in Cycles you'll have to create an Image Texture Node in your material, don't connect it to anything, select your image and bake with the node selected. Bake in Blender Render

$\endgroup$
  • 2
    $\begingroup$ If you are in Blender Render you will also have to go into edit mode and select all, then select/add your image. $\endgroup$ – JakeD Aug 23 '16 at 13:39
  • $\begingroup$ @pycoder it works in edit mode as well, you just have to have the object you want to bake selected. i.stack.imgur.com/6DbG0.gif $\endgroup$ – palkonimo Aug 23 '16 at 14:47
3
$\begingroup$

Here's another one: make sure the "Use scene's active layers and camera" little button, just near the layers grid on Object Mode, is on:

hit dat button!

All kind of weird things were happening to me (including baking problems) until I found out.

$\endgroup$
  • $\begingroup$ That was my problem, thanks for helping. $\endgroup$ – Elektro Javorski Jun 13 at 19:47
2
$\begingroup$

I ran into this issue as well. Took me a while to realize that I have the mesh unselectable by disabling the mouse pointer. After I toggle it back on as below. It is able to bake now.

enter image description here

$\endgroup$
1
$\begingroup$

The camera (render) button in the Outliner next to eye (visibility) button also has to be on for both of the meshes. If it's unchecked for the object baked to (if baked is done from selection to active) there will be error as in the original post.

$\endgroup$
  • $\begingroup$ While this is not the case in the original post, unrenderability of the object can be a reason for the error $\endgroup$ – Mr Zak Mar 15 '18 at 14:22
1
$\begingroup$

click on the enter image description here

Blender has to know which object. Once you see the orange highlight means you are good to bake your image map

$\endgroup$
0
$\begingroup$

Go to: Object mode, Tools, and change shading to flat

Edit:

Sorry I was wrong. First make sure that you have an image and it should be open in the UV editor then You just have to select "Selected To Active" then press bake.

$\endgroup$
  • 1
    $\begingroup$ Shading won't make object have an image avaible for baking to it $\endgroup$ – Mr Zak May 27 '18 at 13:22
0
$\begingroup$

Also, another thing can happen. Make sure "Bake to Vertex Color" just above "Clear" is checked off in the Baking panel.

This just happened to me. I must have selected it accidentally.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.