0
$\begingroup$

I don't see any way of disabling the mouse wheel, or at least to make it not control the zooming. The reason I need to know is that my mouse has an extremely sensitive wheel and I end up zooming in and out uncontrollably when I'm just trying to rotate the view, which is obviously something I need to constantly do. I used some registry edit method to disable the mouse wheel but it only seems to affect some programs and Blender is not one of them. I'd appreciate any help.

$\endgroup$
  • 1
    $\begingroup$ It seems that what you are asking should be resolved through settings on the operating system. On windows look for the mouse properties i.stack.imgur.com/0XrRB.jpg $\endgroup$ – cegaton Aug 22 '16 at 5:50
  • 1
    $\begingroup$ Sounds like you need a better mouse. $\endgroup$ – Ezra Aug 22 '16 at 8:30
3
$\begingroup$

It should be doable by removing (or changing) the Key Bindings in Blender. Go to File -> User Preferences -> Input and look for any Key Binding which is connected to the Wheel of the mouse. Like this:

Disable Wheel

In the example I'm deleting the binding for the Zoom in 3D View only. So in 2D Editors, you could still use it if you like. Otherwise, you'd need to remove it section by section.

To get it back, use the Restore button that shows up after you change or delete a binding (it will stay there as long as your keymap is different to the Defaults). If you want to keep your Blender Prefs this way, click Save User Settings

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.