0
$\begingroup$

very new to Blender (as of about 3 hours ago), so hopefully this will be an easy one. I'm going through video tutorials and I've noticed a discrepancy between the outcome of subdividing on the videos, and on my laptop.

Firstly, I create a new plane. Next, I select the top and the bottom vertices and subdivide them. This causes a new edge to be created between them, with a face on either side of it. Perfect.

Subdividing opposite edges

Finally, I select the right face and subdivide it. This causes it to break up into 4 smaller faces (brilliant), but the left face doesn't automatically break into 3 triangular faces. I'm pretty sure it should break up automatically to deal with the extra vertex that has now been added in the middle of the central edge. All that seems to happen is that the 'centre point' of the left face moves slightly to the right.

Left face isn't broken up into triangles...

I know that I can hit Ctrl+T to break it up into triangles manually, but I really don't want to have to do this every single time I subdivide an adjacent face.

If it's at all relevant, I'm running Blender v2.76 with Ubuntu 16.04.

$\endgroup$
  • $\begingroup$ What is the aim to have these triangles automatically ? $\endgroup$ – lemon Aug 18 '16 at 2:42
1
$\begingroup$

So...It is, but it isn't.

I'm betting you are watching some older tutorial videos (circa 2013) because that was old Blender subdivide behavior (circa v2.53). Subdividing or otherwise changing the edge-count of a polygon ran the risk of an edge explosion to keep all polygons on a mesh either quads(4 edges) or triangles (3 edges).

Blender, as of around version 2.56, recieved N-Gon support. N-Gons is the colloquialism that refers to polygons with 5+ edges, and Blender then began to hold them more or less as-is. This allows for more or less non-destructive polygon slicing, which is what you are experiencing.

Under the hood, it is tracking just a bunch of triangles though. If you want to see and manipulate those triangles, triangulate is ctrlt while the faces in question are selected.

You might want to find more recent tutorials, as well.

$\endgroup$
  • $\begingroup$ @TinyDancer I would add that if you want the original behaviour shown in the tutorials you saw you just have to enable Quad/Tri Mode, shown in the bottom left of your screenshot. $\endgroup$ – Ray Mairlot Aug 18 '16 at 16:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.