1
$\begingroup$

I'm newbie to Blender.

Please see the following screenshot.

enter image description here

I've unwrapped the UVs for the mesh, generated a test image, set the 3D view display mode to Texture. But the texture does not show on the mesh.

In fact, for some time the texture was displayed on the meshes. But one day I tried to unwrap a remaining mesh, the texture was not displayed on that mesh. I tried a few menus, but failed.

Then I removed the test image by Shift-clicking 'X' button on the UV image name widget, saving the file, and reloading. Then... all meshs lost the texture.

It seems that the texture link of the UV map is lost. How can I recover it? And, how can I apply texture to the remaining meshes that refuse to display the texture even after the UV unwrapping?

$\endgroup$
  • $\begingroup$ How does your material setup look like? $\endgroup$ – metaphor_set Aug 16 '16 at 15:21
  • $\begingroup$ See blender.stackexchange.com/questions/5283/…. The mesh might even not have UV map (Blender Internal only), but you need to select all its faces in Edit mode and open desired image. Shift-clicking X button - that's how it works. $\endgroup$ – Mr Zak Aug 16 '16 at 17:33
  • $\begingroup$ Is the texutre assigned to the material? $\endgroup$ – cegaton Aug 16 '16 at 19:51
  • $\begingroup$ @MrZak Thanks! It was very simple. Select all its faces in Edit mode, and open a desired image or just open the image list on the lower left of the UV editing window, and select an image. If you post this as an answer, I'll choose it as the answer. $\endgroup$ – zeodtr Aug 17 '16 at 14:25
2
$\begingroup$

To show texture on the mesh in Blender Internal it's enough to open / create an image texture in UV / Image Editor (or choose already existing one from the list of the images in the .blend file) while all faces of the mesh are selected in Edit mode.
The mesh even doesn't need to be UV unwrapped (although it isn't a good solution as there isn't any control of the image assignment).

screenshot of showing texture in 3D viewport

Note though that it's necessary to unwrap the mesh in order to control appearence of the texture on it and open desired image in UV / Image Editor with all faces selected.

The last step in order to show assigned image in the 3D Viewport is either to enable Texture Shading (note - lighting setup will be taken into account) or enable Textured Solid (note - assigned face textures will be displayed) in the Properties shelf > Shading rollout.

See more on previewing textures in 3D Viewport -How to show textures in the 3D View editor?.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.