I feel as if someone had messed with auto-correct on my phone, and now I can't do anything. Basically, I don't know how this happened, but the left click button only adds mirror modifiers to objects. It does not move the 3d cursor. Every time I click to the left it says "Add Modifier" and it has the mirror as the selected one. Can anyone help me with this?

  • $\begingroup$ What does LMB show for its default in user prefs? Have you by chance changed any hotkeys? $\endgroup$ – Timaroberts Aug 16 '16 at 5:04
  • $\begingroup$ for testing purposes, try resetting to factory settings. The command is in the file menu. Check if the issue persists. most likely you accidentally messed up your keymap somewhere, which can be fixed rather easily. $\endgroup$ – aliasguru Aug 16 '16 at 5:39

There seems to be a keymap added to your system (most likely accidentally), which calls the add modifier operator, and its default is the mirror one. Go to your User Preferences -> Input section, and search for 'modifier' in the 'Name" field:

remove keymap

If you find a keymap like the one in 'nicely drawn' brackets in the screenshot, remove it by clicking the X button (marked with the arrow).

More interesting is actually how you got there. I did it like this: I clicked the 'add modifier' command in the Spacebar menu. The Properties Panel one works of course as well. When the menu pops up, I RMB clicked on the Mirror Item, which brings up another menu. I chose 'Add Shortcut', and simply LMB clicked in there. And the damage was done :)

However, it's not exactly what you have, as my version automatically adds a Mirror, it does not open the menu any more. I had to manually clear the 'Type' field in the Keybinding (see screenshot, bottom right) to have exactly your behavior. Maybe now you can remember how you achieved it? Just played with keymaps maybe?


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.