1
$\begingroup$

I tried to create a transparency but couldn't get it work. What is that I did wrong? :) The black background is still there and not getting transparent. I also tried to invert the shaders in the mix shaders but then averything disappears, even the white and red surfaces.

$\endgroup$
  • $\begingroup$ Try duplicating the image node and setting it to Non-Color for the alpha channel. Also, if you could, it would be a lot more helpful to have a picture with the alpha channel going straight to the color node on an emission shader that goes to the surface input. Otherwise, it'd be nice to see a .blend. My guess is that the alpha channel isn't really changing across the texture. $\endgroup$ – JakeD Aug 15 '16 at 11:21
  • $\begingroup$ I only add to "pycoder" comment: It look like there is no alpha channel in image. This also happen when you use "Image as Plane" addon and you don't check "use alpha" in import settings. $\endgroup$ – Shubol3D Aug 15 '16 at 11:32
  • $\begingroup$ @Pycoder, Shubol, I tried these but still didnt get it right. I also added the files in the post. My picture is a png but without an alpha channel in it, only black to be converted as alpha in blender, I tried with import as plane, check "use alpha" but what I need is that Blender interpret my black surfaces as transparent somehow. $\endgroup$ – TomCG Aug 15 '16 at 13:03
  • $\begingroup$ @TomCG please pack the image that you are using into the blend file and upload the file again. $\endgroup$ – cegaton Aug 15 '16 at 13:14
  • $\begingroup$ @TomCG please read this link: blender.stackexchange.com/questions/27633/… $\endgroup$ – cegaton Aug 15 '16 at 13:15
1
$\begingroup$

Your alpha channel is mostly white. try to make it better or use this trick to use the black color as black alpha.
enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.