5
$\begingroup$

Blender version 2.77a (According to splash screen)

enter image description here

In this image, you can see the outline of a selected/active mesh on the right-hand side. The 2D background image is an "Empty" entity assigned to it an image. On the left-hand side you should be able to make out the black outlines of non-selected/inactive meshes. Everything normal so far.

The left-hand meshes were created before the Empty was created. (I had the image opened in GIMP and modelling the mesh within blender on its own.) This is a brand new file. No fancy options or anything. Literally started blender, deleted startup stuff, changed the world grid properties, enabled Snapping (to increment), and then created a "Grid" for each room and using Extrude and Subdivide to shape it.

The final bit of context/info: the image has a Z of 0. The meshes start as "Grid" at 0, but I extrude walls 200 above, and water pits 200 below 0. So they're 400 tall with the middle/floor being at 0.

Now here is the problem:

enter image description here

When I deselect the right-hand mesh, it disappears from view. It is still there, and if I hit Z to make meshes solid again, it will reappear.

enter image description here

If I change the angle with Numpad 1, the mesh re-appears when not selected, but the lines that are supposed to overlap the image disappear "behind" it regardless of what angle I'm looking at. On the left of the third image you should be able to see black lines going over the bright blue. The black lines do not go over the bright blue on the right-hand mesh.

So the point I'm trying to make is: Why do meshes created after an "Empty (Image)" disappear behind it? What can be done to fix this unwanted behavior?

$\endgroup$
  • $\begingroup$ in the view tab, what are the near and far clipping values? $\endgroup$ – aliasguru Aug 14 '16 at 19:58
  • $\begingroup$ The near value is 0.100 and the far is 100,000.0 $\endgroup$ – Majora Aug 14 '16 at 21:36
  • $\begingroup$ For testing purposes, try setting near clip to 10, or even 100, and lower the far clip as much as possible. See if that solves the issue $\endgroup$ – aliasguru Aug 15 '16 at 5:31
2
$\begingroup$

Your problem comes from the "X-Ray" object's display option.
I tried to reproduce what you described :
same problem
The object on the left has not the option checked :
no x-ray
The object on the right has it :
x-ray

$\endgroup$
  • $\begingroup$ Ohhh, I don't even remember messing with that option. However, toggling it has solved my problem. Thanks! $\endgroup$ – Majora Aug 17 '16 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.