1
$\begingroup$

In the same file on the same level in the same viewport, importing the same object (a pair of glasses, OBJ) one has transparency the other doesn't seem to be able to go transparent even tho the preview orb is transparent. I even changed the material to the lens that was transparent and that did work either.

I haven't edited any any nodes.

The viewport shading is set to material.

What should I pay attention to in order to make the lenses show transparent.

$\endgroup$
6
  • $\begingroup$ Could you post a .blend? More details in your question? Problems like this are hard to solve w/o a detailed question and .blend. You can use this to post a .blend. $\endgroup$
    – JakeD
    Commented Aug 10, 2016 at 14:03
  • $\begingroup$ I just discovered that the lenses are transparent it is just that the head, hair, eye balls behind them are set to not show through transparent layers as I can see other things place behind the glasses. So what setting allows objects to be visible through transparency? $\endgroup$ Commented Aug 10, 2016 at 14:14
  • $\begingroup$ Is the transparency using mask mode? $\endgroup$
    – JakeD
    Commented Aug 10, 2016 at 14:22
  • $\begingroup$ Not mask mode, Z Transparency $\endgroup$ Commented Aug 10, 2016 at 15:38
  • $\begingroup$ Please upload your .blend (and it would be good for you to add 4 more tags btw) $\endgroup$
    – JakeD
    Commented Aug 10, 2016 at 16:09

1 Answer 1

1
$\begingroup$

The problem is actually just a viewport deficiency. If you switch to rendered view or render out a shot, all is well :)

Blender's viewport only attempts to make it look right...to see what's really happening, render it out.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .