3
$\begingroup$

I have a model I generated that has a rig. I added a couple pieces of clothing and want it to adjust when I move the bones and shape keys. I'm not sure how this should work at all. Here's a screenshot:enter image description here

I thought the issue might have been caused by appending, but that appears not to be the case, as metaphor-set points out.

Edit: Here's the link:

$\endgroup$
5
  • $\begingroup$ This should not have to do anything with appending objects. Look at this: imgur.com/a/NsgAW . I appended these 10 rocks to a new file, each of them is still editable and weight paint also works... $\endgroup$ Aug 10 '16 at 6:27
  • $\begingroup$ Yeah, but I clicked the append button and got an error saying I can't edit a linked object. And it wasn't just a one-time thing. I kind of got around it by exporting and importing, but that destroys my mesh, changing it all to triangles. And blender doesn't get the tris to quads quite the way it was. $\endgroup$
    – AaronF
    Aug 10 '16 at 6:45
  • $\begingroup$ Still it's not only about appending. There is clearly something different involved. Also exporting/importing does not necessarily change quads to tris, if done right. Consider uploading your file to blend-exchange.giantcowfilms.com if you want someone to take a look at it. $\endgroup$ Aug 10 '16 at 7:05
  • $\begingroup$ Yeah, you're right. It looks like it was some kind of bug. It stopped when I closed and re-opened blender. Still can't get the clothes to follow the person, though. I added a link. $\endgroup$
    – AaronF
    Aug 10 '16 at 23:42
  • $\begingroup$ This isn't an answer but an add on to this question since the site won't let me add a commment. In relation to number 5 of your answer Drudge, what does it mean when the options in the operator can't be modified?? I followed the steps, but when I tried to set the source layer, blender wouldn't let me in. Pic will be posted to show you what I mean.![enter image description here](i.stack.imgur.com/Qf2iF.png) $\endgroup$
    – Mugen893
    May 24 '17 at 22:27
5
$\begingroup$

The problem is that your clothing has no vertex weighting, only empty groups. The solution is to delete the existing vertex groups on the clothing, then transfer the weights from the body. To do this:

1) Select the clothing and put it into weight paint mode.

2) Select the body and put it into weight paint mode as well.

3) While the body is selected, shift+select the clothing. The clothing will now show as selected.

4) Use the Transfer Weights button in the left tool shelf.

5) In the Operator (lower corner of the left tool shelf after you hit transfer weights) make sure that Source Layer is set to By Name, or it will only transfer the active bone/group.

Note that you may wish to hide the rig, as if you have a single bone selected, it may transfer only that bone.

You can also do this with the Data Transfer modifier.

$\endgroup$
2
  • $\begingroup$ Thanks, it worked. I don't quite understand why it worked, so I'll look into that. But thanks! $\endgroup$
    – AaronF
    Aug 11 '16 at 0:21
  • $\begingroup$ The Armature moves the vertices of the mesh based on their vertex group weighting to each bone. You had the armature modifier, so technically the rig was working on the mesh, just by 0 influence. Now it has weights matching the body beneath it, so it works. Note that for clothing that isn't skin tight, you'll need more advanced weight painting or further rigging just for the clothes. $\endgroup$
    – Ascalon
    Aug 11 '16 at 0:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.