I was practicing with modeling a leaf using a image reference. Everything went fine and I finished modeling my leaf, but I wanted to make it more realistic (I'll add textures later), I saw lots of people using the Subdivision Surface modifier but it doesn't work for me.

My model: My 3d Model

My model when I add the Subdivision Surface modifier My 3d Model when i add subdivision surface modifier

Finished Leaf


4 Answers 4


The mirror modifier is designed to work properly with the subsurf modifier. You shouldn't have to do anything extra.

The main problem is that your subsurf modifier is above your mirror modifier in the stack. The subsurf should be below the mirror modifier.

Essentially, you're suburfing one half all by itself, and then mirroring that. Rather, you want to mirror the part you have, and then subsurf the whole thing.

If that doesn't fix all of the problems, there are some other problems you might be running into.

Normally, the mirror modifier will merge vertices from one half that are close enough to the save vertices from the other half. You just have to make sure of two things:

  • Your center line must be perfectly straight.
  • Your center line must be close enough to the mirror pivot.

To make your center line perfectly straight, select all the vertices that are on the center of your mesh and scale to 0 only on the proper axis. If your center line parallels the x axis and lies on the x-y plane, then scale to 0 on the y-axis.

To make sure your center line is "close enough" to your mirror pivot, first determine what your mirror pivot is. The default is the object's origin, but you can use the origin of another object. In your case, it's probably the object's origin. Here's a method you can use:

  • Select all vertices
  • Zoom in on the object's origin (orange dot) and move all the vertices until the center line lies exactly on the origin.

You may have to zoom in very far to get it perfect, but you really only have to get "close enough" as defined by the merge distance set in the mirror modifier.

It's best to move on a single axis, which you can do after starting the operation, in this case grab. After typing g, type the letter of the axis along which you want to move the vertices. You'll be constrained to this axis until you choose another one, or finish the operation.

  • 1
    $\begingroup$ Cool thanks :D it worked , but i dont really like my leaf xD it's horrible and it doesnt seem a leaf :) But thz for answering maybe i can it apply it next time :) Look at the image of the finished leaf xD $\endgroup$
    – user2087
    Commented Jan 7, 2014 at 17:11
  • 2
    $\begingroup$ Nah, that looks alright to me! You might want to sharpen the corners/points a bit, and it needs all the rest of the texturing stuff (spec map, normal map), but it's a great start! Don't throw away a good foundation, just cuz it isn't finished yet ;-) $\endgroup$
    – Matt
    Commented Jan 7, 2014 at 18:09
  • $\begingroup$ Any suggestions for solving this same issue with a multires modifier as opposed to a subsurf modifier? $\endgroup$
    – Tyler
    Commented Oct 18, 2017 at 21:18
  • $\begingroup$ Multires is a whole 'nuther animal (as we say in Texas). It's not designed to do procedural things like the mirror modifier does. Its whole point in existence is sculpting, which is specifically custom. This is why (from the docs): "The Multiresolution Modifier is the only modifier that cannot be repositioned in the stack if it means that there will be geometry or other object data created or removed before it (e.g. all Generate, some Modify and some Simulate modifiers cannot come before the Multiresolution Modifier.)" $\endgroup$
    – Matt
    Commented Oct 19, 2017 at 15:21
  • $\begingroup$ The solution would be to either finish the sculpt, apply the multires, and mirror after you're done sculpting. OR apply the mirror modifier BEFORE adding a multires, and then use the mirror settings on the sculpt tool instead of using a mirror modifier. $\endgroup$
    – Matt
    Commented Oct 19, 2017 at 15:23

I also had this problem,

In addition to the above which is correct (making sure your subsurf modifier is below the mirror modifier, and making sure that all your vertices are lined up cleanly along the mirror axis)

my problem was that I had some faces on the inside edge of my model. To fix it I deleted the mirror modifier, selected the faces on the inside edge and deleted them. Put back the mirror modifier and voila working.

Just posting in case someone else gets stuck on it. It had me puzzled for a while how there could be a seam or split down the middle of my model with the subsurf on.

  • $\begingroup$ Very helpful tip right here. $\endgroup$
    – work-ed
    Commented Jan 27, 2021 at 21:53

For anybody coming across this thread, I want to chip in years later. I'm having the same issue but all the solutions described aren't relevant in my case. My mesh and modifiers are already well organized. But I have found that changing the Merge Distance in the Mirror modifier affects the pinching. Changing the value may somewhat solve your problem.

In my case I wanted to apply the SubD modifier, which caused the pinching. Prior to that, the model was fine.


You are using mirror modifier with subsurf modifier. That's why your leaf is behaving like above picture. You need to add edge loops or use edge crease to solve this problem.

By the way, this is not the most efficient way to create a leaf. Search for "Sintel LowPoly Plants" video on youtube.com to learn the basics of Low Poly modeling of plants.

  • $\begingroup$ Adding edge loops doesn't actually solve the problem, AND it adds complexity, AND it introduces the potential for other problems down the road. $\endgroup$
    – Matt
    Commented Jan 7, 2014 at 15:27
  • 1
    $\begingroup$ woow. it seems i accidentaly deleted some lines from the answer. cause in first lines, i suggested to move mirror on top of subsurf. :) $\endgroup$
    – Ali Jibran
    Commented Jan 7, 2014 at 16:19
  • $\begingroup$ Oops! Well, edit your answer and put 'em back! ;-) $\endgroup$
    – Matt
    Commented Jan 7, 2014 at 16:27
  • $\begingroup$ its alright. you answered it in detail. $\endgroup$
    – Ali Jibran
    Commented Jan 7, 2014 at 16:36

You must log in to answer this question.