1
$\begingroup$

I am importing images as planes for a 2D animation in blender, however all the PNGs have a white outline and what looks like a drop shadow around the images. Any idea on how to get rid of it? Any help will be much appreciated!


Below are the screenshots. I'm not sure which settings I should be looking for. Import settings, Materials or Textures?

White Border

White border and shadow around houses

$\endgroup$
  • 3
    $\begingroup$ Hi, could you add a screenshot please? $\endgroup$ – batFINGER Aug 6 '16 at 18:15
  • 4
    $\begingroup$ Please upload an image that shows your problem and also shows the settings you are using. $\endgroup$ – cegaton Aug 6 '16 at 18:15
  • 1
    $\begingroup$ Please add an image $\endgroup$ – Billy S Aug 6 '16 at 19:39
  • $\begingroup$ In addition to a screenshot, please also include what version of Blender you are using. I think in 2.75 they changed the alpha on the import and how to tell it to use it. $\endgroup$ – Gliderman Aug 6 '16 at 21:39
  • 1
    $\begingroup$ @user29252 to make screenshots in blender press Ctrl F3. Then use the edit link at the bottom of your question to add more information to the question. $\endgroup$ – cegaton Aug 8 '16 at 15:18
2
$\begingroup$

Blender's 3D view has some problems compositing planes with alpha in OpenGL mode. You can mitigate those effects to some extent (by changing the alpha clipping in the preferences or the different viewport alpha settings in material properties) but don't expect to have a perfect compositing of RGBA texture in the viewer, as Z compositing and Alpha compositing sometimes fight each other when selections are involved.

Render should turn out ok. If it doesn't, then there is a problem with your PNG images (wrong alpha association).

Wrong alpha association could be fixable (using the CM panel of the Image viewer if it) ONLY if the halos are the result of an incorrect alpha interpretation. If the image is encoded incorrectly, then there is no way to solve it, other than recreating the image textures properly.

Blender usually interprets PNG textures correctly if they are properly encoded, so check with a test render first. If it renders ok, and the halos pop up and disappear based on what's selected, then it's just the problem described first and you can't do really much about it other than trying to mitigate it as much as possible (which is probably a waste of time since it doesn't affect rendering)

$\endgroup$
0
$\begingroup$

Disable/change interpolation in the Image Sampling panel for your texture, or try changing the alpha mode. If these don't work, the problem is likely with your texture and needs to be fixed in an image-editing application like Gimp.

$\endgroup$
0
$\begingroup$

I had a similar problem and found the "Transparency" and "X-Ray" boxes could eliminate the outlines. The boxes can be located (and ticked) under the orange cube for each plane in the Properties panel --> Display. Also make sure you've set the rendering to "Render Only" and possibly also - "World Background". Press N in the 3D window, and open the "Display" tab.

Another odd one, sometimes I need to 'awaken' Blender by jiggling between the "Multi Texture" and "GL" options found in the Shading tab. (press N in 3D window, open "Shading") When things don't work properly the 1st time and I do that, it often corrects itself the 2nd time! (Could be my video card)

Another one I came across when getting white outlines, was my 'trimming' when I'd cut out sections from pic files. I'd have to trim back to exclude the brighter edges of the piece I was cutting out and even paint over those edges! (I was using Gimp at the time)

I've encountered a white border on the bottom of the frame also and fixed that by "scaling", not the plane it was textured on, but the image itself in it's own Texture properties panel --> "Mapping" tab. (SH-Space) In there are x, y & z "size" entry boxes. You can type in very fine adjustments to 3 dec places, or simply slide them left and right for course adjustment. The white borders might disappear for you that way.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.