0
$\begingroup$

I am new to blender and I was wanting to make a FPS game using the BGE. I have my character and rig setup with the right arm a different object so it can move freely while aiming. I set up my camera in front of the seprate arm and when I played the game, the arm disappeared. When i viewed the arm from different angles and played the game, the arm appeared as normal. Does anyone know why this happened? I have some screenshots to help explain the problem. Normal view played

First person view played

The first image is the Normal view. The second image is Viewed from first person.

Thanks in advance.

$\endgroup$
1
$\begingroup$

I'm not entirely sure why this is happening.

However, I found that joining the arm mesh to the rest of the character mesh (with ⎈ CtrlJ) (and joining the two armatures, also with ⎈ CtrlJ) fixed it.

My first thought is that the BGE's view frustum culling was hiding the arm, but if that's the case, I'm not sure why it doesn't also hide the entire character..

$\endgroup$
  • $\begingroup$ This happens when the original bounding box (frame 1) of the skin mesh is outside the camera's frustum. The bounding box will not be updated (for speed reasons). $\endgroup$ – Monster Aug 8 '16 at 6:03
  • $\begingroup$ @Monster In the version with the joined armature/character, it works even when the camera's frustum doesn't intersect the character's un-posed bounding box. How come? $\endgroup$ – gandalf3 Aug 8 '16 at 15:20
  • $\begingroup$ I guess the bounding box is bigger than before. You can see the bounding box by enabling Game/Show Physics Vizualisation. It is the physics box, but it does not change too. (it is not visible when Physics is disabled e.g. set to Ghost)) $\endgroup$ – Monster Aug 9 '16 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.