4
$\begingroup$

When UV mapping I have been running into issues with not everything in an island being connected. I have marked the seams and all the vertices are connected but when I go and try to move an island only part of the selected object in the seam moves.

How do I link the whole island up so that it moves as one?

Example

$\endgroup$
  • $\begingroup$ In one image, you have all the vertices selected, in the other, you don't. Try pressing <kbd>A</kbd> until all the vertices are selected (highlighted orange), and then moving them. $\endgroup$ – Gliderman Aug 5 '16 at 21:57
  • $\begingroup$ I tried that and it automatically deselects part of the island. $\endgroup$ – Jared Aug 5 '16 at 23:07
  • $\begingroup$ That's why I said to press it until- Oh, I see where that can be confusing. Press A multiple times until they are all selected. A toggles on/off on the selection. $\endgroup$ – Gliderman Aug 5 '16 at 23:09
  • $\begingroup$ Here is a video of my attempts to do this after pressing A on the keyboard multiple times. It still deselects part of it when trying to move it. youtube.com/watch?v=I8n95BbzGxk&feature=youtu.be $\endgroup$ – Jared Aug 5 '16 at 23:59
  • $\begingroup$ Huh, that is weird. I haven't seen that before, but it is looking like aliasguru's answer may be the solution. $\endgroup$ – Gliderman Aug 6 '16 at 15:00
3
$\begingroup$

It looks like this is a coincidence of a few things. When trying this on my machine, I can replicate the behavior if I do the following things at the same time:

  1. I am in UV Sync Selection Mode
  2. I have select UV islands enabled
  3. I try to move the UVs not by using g, but by click-dragging with the mouse instead

check the five icons on the bottom right of this screenshot:

island selection

the one on the very right is the UV islands selection mode, it is enabled. You only see this if the fifth icon from the right, the one that looks like an arrow over a cube, is disabled. This icon toggles the UV sync option. If it is off like now, you only see UVs for vertices which are selected in the 3D viewport. So make sure that in 3D View, all vertices are selected.

Now the crucial part:

The click-dragging actually updates your selection before the moving starts in the UV editor, and selects (in this case) only the one island under the mouse cursor. This behavior is sometimes called 'tweak mode'. If you select first, and then hit g to go to translation mode, the whole stuff translates, no matter if it is connected or not.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.